Makarov Won't Fire - Please Help


PDA






DougB
September 16, 2004, 03:30 AM
A friend of mine recently tried out his new (used) Bulgarian Mak and reported this: "I got it to fire once when I first racked a round but after that the hammer doesn't strike the firing pin when the trigger is pulled. Any suggestions?"

Any ideas? I own several Bularian Maks and have never seen a problem like this. I'm wondering if his firing pin may have broken on the first shot, but I haven't had a chance to examine the gun. Or could the safety be somehow misaligned so it is blocking the hammer but still allowing the trigger to function? I'm hoping there's some simple, easy to fix. Any thoughts would be appreciated. Thanks.

Doug

If you enjoyed reading about "Makarov Won't Fire - Please Help" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
lee n. field
September 16, 2004, 09:43 AM
I think you're going to have to examine the gun. Disassemble and clean if necessary.

Drakejake
September 16, 2004, 09:49 AM
I have an East German Mak that won't fire double action, but works well single action. I have replaced a number of parts without solving the problem. The strange thing is that if I exchange its slide with that of another Mak I have, both guns fire double and single. I have given up on this problem because I have tried everything I think of over and over without any luck.

Drakejake

Trebor
September 16, 2004, 03:19 PM
Remove the safety. Once you have the safety off, you can check the firing pin. Make sure it isn't broken and clean all the gunk out of the firing pin channel. Pipe cleaners work wonders for this.

Also, check the detent spring that holds the safety in position. It can become worn so that it allows the safety to ever-so-slightly move under recoil. This will keep the firing pin from hitting the primer. The fix is easy. Just use the appopriate tools to rebend the spring slightly to increase the tension. Don't bend it too much or you'll make the safety difficult to move.

Try these things and I'll bet the problem will be solved.

denfoote
September 17, 2004, 09:25 AM
My first thought was cosmoline in the firing pin channel!!!
Follow this link. (the whole article with pics takes up to much band width)
This will help!!! :D

http://makarov.com/tech/assembly.html

DougB
September 17, 2004, 01:58 PM
Thanks for the suggestions - much appreciated. It sounds like we need to thoroughly clean the firing pin channel and make sure the safety is staying firmly in the "Off" detent. I haven't had a chance to look at it yet, but now I have some good ideas of what to check. Since I've got several Bulgarian Makarovs of my own, we can also experiment with swapping out firing pins and safety levers to see if there's a problem with those parts.

Thanks again.

Doug

If you enjoyed reading about "Makarov Won't Fire - Please Help" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!