Help please--very quick Savage question!


PDA






Chairman
December 2, 2004, 03:19 PM
I just bought a Savage 10FP .308 off Gunbroker and have a question for other Savage owners. On my supposedly NIB gun, there is no finish around the scope mount screw holes in the top of the receiver; it almost looks like a scope had been mounted and the finish removed--is this typical of Savage 10FPs as they come from the factory?

Also, the factory stock seem to be significantly warped--when the forearm is resting flat (on a rest or a bipod), the top of the buttstock seems to be canted about 10-15 degrees. I assume this is not normal??

Thanks!

If you enjoyed reading about "Help please--very quick Savage question!" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
H&Hhunter
December 2, 2004, 04:08 PM
I do not own a Savage 10FP. But none of the things you've mentioned would occur on a new rifle. If it looks like it's had a scope on it. It has. As far as the warped stock thing well it could be a factory defect but I wouldn't accept a rifle like that I'd send it back!!

Also just because the rifle had a scope mounted on it doesn't mean it's been shot.

Just something to consider.

ocabj
December 2, 2004, 04:35 PM
While the synthetic stock on the base model 10FP is garbage, it shouldn't be warped. As far as the marks on the receiver, the only reason why it would have been mounted with a scope and still considered new from the factory is if it was a 10FP packaged deal from Savage where they sell the 10FP with scope, base and rings, bipod, sling, and case.

R.H. Lee
December 2, 2004, 04:43 PM
I have a 10FP in .308, and the blueing around the scope mount screwholes was intact when I purchased it new. The stock on this rifle is too weak and flexible to support a bipod. I've tried it with a Harris bipod and the rifle was not level, it canted, but I don't remember which way. A stock replacement is on my "to do" list.

Chairman
December 2, 2004, 05:00 PM
Thanks for the replies so far!

I looked closer at the finish around the screw holes and it appears to be something black over the factory black (phosphate or similar?) finish. Could it be leftover epoxy from a bedding job, or just a lot of excess loctite? It scrapes off relatively easily. I attacehd photos below.

The stock is canted with or without the bipod, even without the action in the stock. It appears that the front 6 inches or so is slightly twisted. I talked to Savage--all they said was send it in.

I sent an email to the Gunbroker seller I bought it from--we'll see what he has to say.


http://img.photobucket.com/albums/v494/Adam7373/rearscopeholes2.jpg

http://img.photobucket.com/albums/v494/Adam7373/frontscopeholes2.jpg

RRTX
December 2, 2004, 05:59 PM
Looks like it had a scope base or something put on at some point to me, my 10FP has perfect finish around the mount holes. The factory Savage stock is junk, but mine is not twisted in any way, although the forearm does flex very easily. The rifle itself can't be that old since it appears to be an accutrigger model, I bet they just stuck a scope on it for show at the shop or something.
http://www.thehighroad.org/attachment.php?attachmentid=&stc=1

rbernie
December 2, 2004, 07:13 PM
Looks like some locktite that oozed under the mount from the screwholes. This is either a used rifle or (more likely) one of the Savage package deals that had the scope/rings/mounts pulled off.

If you enjoyed reading about "Help please--very quick Savage question!" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!