CZ 52 problem


PDA






longrifleman
January 16, 2005, 07:54 PM
I purchaced a $89.00 special CZ 52b from Aim about a week ago and have been having a problem with it. It was in prety good shape visually with normal holster wear on the corners and minimal wear to the slide etc. It feels tight and everything functions manually.

The problem is that about one round in every magazinte locks up the pistol with the slide about .5 in from going into battery. The slide won't move without much jerking, banging and assorted bad language. I really don't like treating a loaded pistol the way I have to to get the slide to work. The round in the chamber appears to be good. No corrosion, still round and the bullet on the right end.

The rollers appear to my eye to be in good shape and so does the locking recesses. I haven't tried to measure them as I don't know what they should be anyway.

At first use I oiled the pistol lightly, the way I would my other semis. When it still wouldn't function I tried a heavier coat and that still didn't work.

Any ideas would be greatly appreciated.

If you enjoyed reading about "CZ 52 problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
DnPRK
January 17, 2005, 10:30 AM
My guess is that the case rim is not sliding up into the extractor as the cartridge is being chambered. Clean the extractor, check it for burrs, oil it and make sure it moves freely under spring tension.

tommyt
January 17, 2005, 11:05 AM
What kind of ammo? I'm guessing the pistol is nice and clean?

If you enjoyed reading about "CZ 52 problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!