SA XD not locking back on last round


PDA






2t2 crash
February 28, 2005, 08:43 PM
Just curious to all you guys shooting XDs, what ammunition do you guys shoot?
I was shooting Remington 115g .9mm luger and It shot fine, but would not lock back on the 10th round.
I am not sure what brand ammo i was shooting the first time but I had no problems then.
Could my pistol just be picky?
When I read my XD as .9mm, what is safe to shoot?
pretty much all .9mm?

thanks.
John

If you enjoyed reading about "SA XD not locking back on last round" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
psyopspec
February 28, 2005, 09:26 PM
Since it's the magazine that activates the slide lock, I'd look into a replacement mag before ammo. Factory 115 gr Rem would provide enough power to cycle the gun when fired. See if SA or the place you bought it will give you a new mag, or just buy another one to try in your gun. If both mags fail to work, then it's likely something is wrong with the pistol.

MrTuffPaws
February 28, 2005, 11:15 PM
Okay, first are you using a 40 mag instead of a 9mm mag? That has been the cause of this issue in the past. If not, then is it one or both mags? If only one, then you can rule out the ammo. If it is both, then get some other ammo and see what happens.

I shoot CCI blazer mostly, but I have shot WWB, and it never gave me any trouble.

2t2 crash
March 1, 2005, 09:33 AM
im in PRK so i have to use the 9mm mags. I think it is the ammo, i'll try a different type next time. while at the range I re-lubricated the pistol and still had the same thing going on.

dolanp
March 1, 2005, 10:06 AM
If it is failing to lock back after the last round is fired I don't see how it can be the ammo. It sounds like your slide lock is not contacting the magazine follower correctly somehow.

Sproles
March 2, 2005, 08:13 AM
If the slide is NOT locking back on last round - check your thumb.

I, too, shoot the XD (sc9) and ran into this problem for awhile until I realized that my right thumb (I shoot righty) was barely touching the slide release while shooting. When the last round was fired and the slide would normally catch, my thumb was touching it enough to release it and make it appear to be NOT staying back. The REAL issue was my own thumb. Check your thumb and see if the same issue is not happening.

Let us know if that does NOT address the problem and we will go from there.

David

Walt Sherrill
March 2, 2005, 08:45 AM
Check your thumb, and check for weak mag springs. If the mag springs are weak, the follower may not be pressing up against the slide stop with enough authority to activate the slide stop.

(The .40 mags should be letting the 9mm round ride a bit higher than it would with a .40 round in it, so the following SHOULD be hitting the slide stop. But THAT would be the first place to look.)

Does the slide lock back on an empty mag?

If you enjoyed reading about "SA XD not locking back on last round" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!