Marlin 60W problems


PDA






mbrubaker
March 26, 2003, 07:59 AM
I have a Marlin 60W .22 semi auto rifle that is giving me problems. Up until I last cleaned it things were fine. Now it has the following problems. (Descriptions are given looking from the bottom. Excuse my terminology - I know it isn't totally correct.):

1. When I install the large metal block that has the cocking arm on the side and spring through the metal rod at the back this part of the assembly mooves back and forth smoothly.

2. As soon as I install what I call the rail piece on top of the above and lock it in with the plastic pin at the back, the action becomes tight and
a. The large metal block will not move back and forth smoothly - it seems to hang up toward the barrel.
b. The mechanism that locks the action open after the last cartridge is ejected does not work on its own.
c. When I cycle the action manually with cartridges the one that should be ejected is not. It is held in place and the new cartridge tries to load at the same time. If I fire a cartridge, the casing does not eject, and is held in place by the ejector fingers on the large metal block.

Any help will be appreciated.

If you enjoyed reading about "Marlin 60W problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
KelBench400
March 26, 2003, 01:59 PM
terminology:
large metal block = bolt
rail piece on top = trigger group
the ejector fingers = extractor

I'm at work, so I can't look at my model 60. It sounds like your extractor is working, but the ejector is not. The extractor pulls the cartrige out from the chamber and the ejector knocks it out of the gun. Yours might have broken.

I'm not sure how the hold-open feature works right now, but if I get the chance I'll take my rifle down tonight and try to take a look for you.

-Kel

KelBench400
March 27, 2003, 01:54 PM
Okay, I took my rifle down last night to look at it. The ejector is simply a spring that is mounted to the same pin that holds both the cartridge lifter and the bolt release lever (hold open). The ejector spring also is used to tension the cartridge lifter and the bolt hold open.

I think possibly your spring has slipped off of where it should be or it has broken or bent. The spring should be sitting on top of the feedthroat (silver rectangle that the cartridge loads through) on the right side of the reciever.

Hope that helps some.

-Kel

mbrubaker
March 28, 2003, 01:23 PM
Thanks for looking, Kel. I will be taking a closer look at my rifle assembly this weekend and let you know what I find.

Mike

mbrubaker
March 30, 2003, 04:03 PM
Kell,

I looked at my Marlin 60W today and found that you were absolutely right about the ejector spring. It had slipped down between the feedthroat and the side rail. I noticed that one of the small e clips on one of the pins on the trigger group had come off or broken off. I replaced that and put the ejector spring back in place. Now the rifle functions as it is supposed to. Thanks for your help!

KelBench400
March 31, 2003, 02:04 PM
I'm glad to hear you got it running again....with a simple fix.

Take care,
Kel

If you enjoyed reading about "Marlin 60W problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!