Light primer strikes in S/A


PDA






mpthole
April 13, 2003, 03:20 PM
I didn't know if I should post this here or in the reloading forum...

My problem is that I'm getting light primer strikes when in single-action mode on my USP .45 Compact on my reloads only. When shooting any factory ammo I have never had this problem. Most of the time if I re-insert the bum round it will go off when I fire in double-action. I'm using Winchester Large Pistol Primers and they were all loaded on a Dillon 650. I get one of these bad rounds maybe 5% of the time.

Any ideas out there? Could it be a moisture problem? These rounds were loaded over a year ago and have been sitting in a .30 cal ammo can w/o dessicant. They've been moved from garge to house to truck and back-and-forth countless times... and in this area (MN/WI) that means from below 0 to over 100.

:confused:

I was using these reloads for IDPA but am getting frustrated with them because of all the above problems. Of course, I could look at it as a training opportunity and train myself to automatically rack the slide when it doesn't go 'boom' when it should.

If you enjoyed reading about "Light primer strikes in S/A" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
JohnKSa
April 13, 2003, 07:19 PM
A couple of things.

1. The SA strike is usually HARDER than the DA strike. That's because the SA notch usually places the hammer farther back than the position where the DA pull releases it.

2. It sounds like your reloads are going too deep into the chamber or you are using primers that are too hard.

bompa
April 13, 2003, 11:34 PM
It is possible that you get a high primer every now and then..

JPM70535
April 13, 2003, 11:55 PM
I second the thought that what you are experiencing is a high primer every now and then. I also load on a 650 and my Para C7-45 LDA is extremely picky as to primer seating depth. If the primer is not completely seated, the hammer fall will not ignite it. All my other 45s with conventional triggers, either straight Single Action ( Springfield) or SA/DA (S&Ws) have no problem with the same "High primers" A second strike always fires the round and FTF never occurs with Factory ammo, One possible cause for the high primer might be not cleaning the primer pockets before priming, something I almost never do when using progressive machines. I have micd the primer depth and there is a measureable depth difference between the fully seated primers and the ones that didn't fire.

My solution, use reloads for practice and use Factory ammo for carry.

cliffdropover1
April 14, 2003, 12:08 AM
I had the same problem using a Dillon Square Deal B. Called Dillon and they suspected the operating handle was cracked and thus not pushing the primer all the way home. They were right. The crack was impossible to see, but the handle did snap a couple days after I made the call. They had already sent me a new handle and upon installation, the high primer problem was solved. Could be a possibility for you too.

If you enjoyed reading about "Light primer strikes in S/A" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!