First time out with new FAL - magazine problems?


PDA






mmike87
March 13, 2006, 09:39 AM
I took my new DSA SA-58 FAL out this weekend for the first time.

What a nice rifle. I really enjoyed shooting it. Very accurate, recoil not bad at all, comfortable to shoot.

I brought three magazines with me to the range. I had numerous FTF's with two of the magazines. The third magazine was flawless once the gas system was adjusted.

I was shooting exclusively SA suplus, which performed admirably. I also followed the standard procedure for adjusting the FAL's gas system.

Are these two mags just trash, or can they be fixed? What should I look for in an FAL magazine? I have some replacement springs ... should I just swap them out? I had also refinished all these mags recently, perhaps some finish gummed something up, although they appear to move freely.

I did notice that with the DSA extreme duty scope mount on it there were brass marks all around the ejection port, which as I understand is normal.

Any suggestions appreciated. Otherwise, I really, really, really liked the FAL.

If you enjoyed reading about "First time out with new FAL - magazine problems?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Nightcrawler
March 13, 2006, 10:17 AM
The problem is in the magazine, not the rifle.

Many FAL magazines need breaking in. That is, the feed lips are a little rough. Did you notice drag marks from the feed lips on the brass?

My STG-58 had this problem. It tends to work itself out as the magazines are used and the lips become "polished".

I had this problem primarily with DSA's Austrian magazines. The magazines from CDNN Investments (Israeli maybe?) didn't give me this trouble, but are harder to disassemble for cleaning.

The only mag I couldn't get to function was an alloy one. I fixed it by throwing it downrange and putting two rounds through it. Hasn't troubled me since.

Also, I had to work on a DSA metric-converted 30-round L4 Bren Gun mag, but it works okay now.

mmike87
March 13, 2006, 10:24 AM
Now that you mention it, there were marks on the case necks of the brass on several rounds. It was very prominent and I noticed it without even knowing to look for it.

Thanks for the information. I am looking forward to shooting the FAL a lot more.

boing
March 13, 2006, 07:35 PM
They'll break in with use, but you can deburr the feed lips with a few light passes of very fine grit sandpaper, to quicken the process. It doesn't take much, and be careful not to remove any material or change the contour of the lips. Just a light polish.

It may also help to load up the mags for a few days and let the springs set.

Bwana John
March 14, 2006, 01:35 AM
I think you will find the problem to be the rough new parking on the receiver feed rails. Either smooth them out with some some emery cloth, or shoot the thing smooth.

Many people have had this problem with new rifles.

I have found that a well broken-in FAL will run like a raped ape with most mags, even ones that appear to have been run over by a half-track

mmike87
March 14, 2006, 07:48 AM
I took a light sandpaper and ran it a few times over the rails and mag feed lips, slightly polishing them. Next time I am out there, I'll see if that helps.

There was alittle rough spot on the left side feed rail in the receiver.

Seven High
March 14, 2006, 09:16 AM
Did the bolt ride over the round that should have been pushed into the chamber? If so, the magazine might be a little loose in the mag well. You might have to build up bottom of the catch on the magazine located at the back of the magazine. J.B. Weld works really well for this. Avaliable at better hardware stores nationwide. :)

If you enjoyed reading about "First time out with new FAL - magazine problems?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!