bolt action sks... ggrrrrr....


PDA






yesterdaysyouth
April 25, 2003, 08:19 AM
so im cracking away then the fte.... hhhmmm... ok just pull the bolt and try again.... it happens again...

now there was a gasket around the gas port, which removed itself from the rifle, i thought that was the problem but my buddies sks has never had that gasket.. so..

im sure this is common, but i don't have any reference material to work from so im blind at this point...

If you enjoyed reading about "bolt action sks... ggrrrrr...." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
MonkeyMan
April 25, 2003, 08:58 AM
My SKS doesn't have a gasket on the gas tube either. What comes to mind first is a problem with the gas piston or operating rod.

Good luck.

Nero Steptoe
April 25, 2003, 07:05 PM
Check for cosomoline in places it shouldn't be.

cool45auto
April 25, 2003, 11:30 PM
Mine doesn't have a gasket either. Make sure you clean the little port at the front of the gas tube real well. If your cleaning kit doesn't have a port cleaning tool you can use a really small round file to remove the build up.

DougB
April 26, 2003, 01:25 AM
This doesn't sound like your problem, but just in case...the Yugo SKSs have a gas cutoff button to facilitate using the grenade launcher. When I first shot mine, I had the gas port turned off so it operated essentially as a straight-pull bolt action (until I realized what was going on and moved the cutoff to the open postion). The button is located near the folding grenade sight, and slides from the top to the side of the barrel.

Doug

yesterdaysyouth
April 28, 2003, 01:10 PM
well i pulled everything apart and cleaned it all out....

when i went to test fire it yesterday, still bolt action..

when it fires the bolt does come back but only about 3/4", i turned the grenade launcher on and fired it, the bolt doesn't move at all... so im thinking the gas port seems to be working, i found a small burr on the bolt just above the firing pin, but i don't see how that would cause this problem... any more ideas??

yesterdaysyouth
April 30, 2003, 04:14 PM
well i tried it again .... nothing new...

after firing the case is rather hard to extract but if i extract a live round it's like butter .... what's up with that?? i know the case neck expands but the case is supported to the rim??

stans
April 30, 2003, 08:21 PM
Hmmm....hard fired case extraction. Could be a headspace problem or rough or pitted chamber or maybe a build up of laquer in the chamber.

yesterdaysyouth
May 3, 2003, 12:40 PM
just in case someone else has the same problems i'll tell you what i found....

put some paper around the gas tube/ valve and the op rod area, ran 5 shots through the gun and could see exactly where the gas leak was at.....

leaking in front of the gas tube/valve .... the right size o-ring in place and it works like new.....

so new valve and gas tube/piston it is..... when i bought the rifle i couldn't see how pitted the valve and tube were but now that it's been cleaned so many times it looks like rough sandpaper...

so when choosing a new sks, and probally ak.... always check for gas leaks before you buy...

If you enjoyed reading about "bolt action sks... ggrrrrr...." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!