Trigger for S&W Model 29-10 50th Anniversary Model


PDA






Eskimo Jim
August 7, 2006, 07:19 PM
Hello,
I just bought a S&W 29-10 50th Anniversary model. The single action trigger is nice and crisp however I find that the double action trigger is almost a two stage trigger. The trigger comes back with a nice steady pull, then gets very heavy and finally releases the sear. I've found this to be different than my other S&W revolvers.

Has anyone else encountered this? I find that right before the double action lets off, the cylinder locks up.

I like just about everything else about the revolver.

Thank you for your replies.

Jim

If you enjoyed reading about "Trigger for S&W Model 29-10 50th Anniversary Model" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Old Fuff
August 7, 2006, 08:01 PM
Remove the stocks and see if the mainspring strain screw (toward the bottom or the forestrap) has backed out, or obviously been shortened (blue gone from the end). If so, screw it in, or replace it as the case may be. If this isn't the answer then someone (you or a pistolsmith used to working on S&W revolvers) will have to pop the sideplate (don't pry it off!) and check the innards to see if a previous owner decided to do an "action job".

Eskimo Jim
August 7, 2006, 08:19 PM
Old Fluff,
Thank you for replying. The revolver is brand new. I'll check the main spring.

Jim

Old Fuff
August 7, 2006, 08:32 PM
Oh Darn!!!

The new guns have different lockwork then the old ones. If you pop the sideplate be very careful because the pin that holds the frame-mounted firing pin tends to get lost. Also if you remove the hand from the trigger the little spring that tensions the hand may fly out and go south. :banghead:

Check the strain screw and then we'll go from there.

Eskimo Jim
August 7, 2006, 08:42 PM
Old Fluff,
Thank you for replying. I don't plan to remove the side plate. If that's the issue then I guess I'll have to send it back to Springfield.

Jim

Old Fuff
August 7, 2006, 10:23 PM
The problem you describe sounds like a backed-out strain screw. If it isn't that I would send it back. When they get it they will go through EVERYTHING, and replacement parts are on them. That's what warrantees are for

But they should have caught it before it left the factory... :cuss: :banghead:

If you enjoyed reading about "Trigger for S&W Model 29-10 50th Anniversary Model" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!