Kimber Pro Carry II


PDA






BulldogUSMC
November 3, 2006, 02:40 PM
Has anyone had any problems with the slide locking will firing?Finally was able to buy a Kimber a couple weeks ago.Went to the range and my CHL renewal class the next day.Put about 350rds total thru it.Kept having problems with the slide lock kicking up and locking the slide open while firing.Never had a problem like that with any other semi.Has anyone else?Suggestions?:cuss: :fire:

If you enjoyed reading about "Kimber Pro Carry II" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
bofe954
November 3, 2006, 05:36 PM
Did you try a few different magazines?

Monkeyleg
November 3, 2006, 05:53 PM
This problem has been addrressed in other threads concerning all different brands and models of 1911's.

Besides the magazine being the potential cause, it may also be the ammunition. The bullet may be making contact with the slide stop, and pushing the stop up as the cartridge moves out of the magazine.

1911Tuner has written several posts about this problem. You might try searching through those.

BulldogUSMC
November 3, 2006, 06:08 PM
I got one 7rd mag with it,but bought 3 of the 8rd Kim-Pro mags and they were the ones I was using.I will try the original 7rd and see what happens.Thanks

asknight
November 4, 2006, 12:27 AM
It could also very well be your technique. Make double sure that the tip of the thumb on your support hand isn't touching, riding, or pressing on the slide lock in any way.

Bill Henry
November 10, 2006, 11:40 PM
Had one with same problem. It was me. My grip was too limp. Try holding on just a little tighter. Many times guns with tight tolerances have the same problem

Bill Herny

If you enjoyed reading about "Kimber Pro Carry II" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!