Possible Stag Lower Problem


PDA






Thrash1982
November 4, 2006, 10:55 PM
I recently purchased three Stag Arms lower receivers and rebuilt my carbine on one of them. After I put on my Magpul M93 I noticed what seemed to be a .25 to .5 degree upward slope to the buffer tube. My suspicions were confirmed when I attached the upper and noticed the charging handle was rubbing against the top of the buffer tube. It doesn't seem to affect the function of the rifle (but I haven't shot it yet). I'm just wondering if having that very slight upward angle on the buffer tube will hurt anything and if anybody has seen anything similar on other Stag lowers.

Thanks all

If you enjoyed reading about "Possible Stag Lower Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
rangerruck
November 5, 2006, 03:21 AM
I would think that this could not be good. As ar's were built to specifically ' hang ' all moving components in a straight, singular line, with only gravity acting on them to keep everything in line. your situation is creating two differing linear planes, with objects in motion, changing from one line to the next, on each shot. Now I am an ar dumb@#$ no doubt, and there are a lot of dudes here with more experience than i , for sure. but it seems to me you are asking for a wear and tear problem, that could be as simple as reducing the lifespan of some of the components, to perhaps a future catastrophic failure, at the worst degree. Do you wanna risk that?

wdlsguy
November 5, 2006, 09:21 AM
Are the other two receivers doing the same thing (with that stock)? If so, there might be a problem with the stock. If not, you should contact Stag, I'm fairly sure they will replace the receiver for you.

Kaylee
November 5, 2006, 10:04 AM
I have an M16A1-era clone built off a Stag lower. No problems, no canting of the buffer tube, no stock/charging handle contact.

Perhaps a bad batch?

Thrash1982
November 5, 2006, 10:10 AM
I suppose it's possible I got a bad batch, but I just put my stock on my other two lowers (which are consecutively serial numbered) and I didn't notice any canting of the buffer tube. It can't possibly be off by much because the charging handle moves freely until about the last .5 to .75 inches of it's travel and even then it' s not rubbing enough to make it difficult to move. The bolt also moves freely within the buffer tube. I'm going to take it out and function check it today. I'll report back in later.

BSlacker
November 5, 2006, 10:16 AM
I have a stag lower with M93 stock and haven't noticed a problem. No rubbing of the charging handle.
Here is a pic of buffer tube and lower.

http://img.villagephotos.com/p/2006-1/1128723/magpul1.JPG

No contact on top.

http://img.villagephotos.com/p/2006-1/1128723/magpultop.JPG

It was used with a Stag upper.:)

Thrash1982
November 5, 2006, 10:30 AM
I suppose it's possible it's the buffer tube itself. Thinking back I noticed some slight wear on the tube when I had it on my Superior Arms lower and would sometimes have to wipe off oil that it would deposit on top of the tube. Maybe I should talk to Magpul about it.

rangerruck
November 5, 2006, 11:34 AM
umm... i don't know if you guys can see it, but something is looking funny in that second pic on that buffer tube.

Thrash1982
November 8, 2006, 05:02 PM
Finally getting around to posting back. I put about 60 rounds through it on Sunday and it ran perfectly. Very happy with it.

Thrash1982
November 9, 2006, 05:03 PM
Thought you guys might like a pic of my rifle.

http://i18.photobucket.com/albums/b122/Thrash1982/Nates11-5-06001.jpg

Correia
November 9, 2006, 05:54 PM
I've sold a mess of Stags, both complete guns and just lowers, and I haven't seen that or had anybody complain.

If you enjoyed reading about "Possible Stag Lower Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!