Savage 110 left hand .270 win. failure to fire


PDA






rugerman
November 9, 2006, 09:45 PM
My son's rifle is having a problem, it started last year when it clicked 3 times before firing when he was shooting at a deer (he got the deer), that was last November I would have figured it due to cold weather and too much lube but we didn't have any cold weather here last year. So I took the bolt and soaked it for a couple of days in mineral spirits then blew it out with carb cleaner and lightly oiled it with breakfree clp and tried it again, worked fine for several shots then click. The same ammo works in both my and my other sons .270's and the clicked rounds will work in them also. The firing pin marks on the cases when it does fire are light and cratered. So I called brownells and talked to tech support and we came to then conculsion that the main spring was weak. I got a new spring (it is 1/2 inch longer than the original) and installed it, I took a measurement of the overall length of the spring part of the firing pin/spring and matched it before reinstalling. Before assembly I cleaned and lightly lubed the interior of the bolt (no there was no crud in then bolt that had caused the failure to fire). After reassembly the click when dry firing was much stronger and sounded like my other sons right hand 110 .270. I primmed a couple of cases and everything seemed fine. Today I took the rifle out and shot it several times with no problems then I dry fired it about 20 times and tried it again and got 3 failures to fire, I brought the rounds home and pulled the bullets and tried them in my #1 .270 and got 3 booms. All ammo is the same that I use in the other 2 rifles with no problems and up until this it has also worked fine in the LH 110. Firing pin protrusion is good now (it was good before) and the primmer is more deeply indented with a small amount of cratering. Any help greatly appreciated. rugerman

If you enjoyed reading about "Savage 110 left hand .270 win. failure to fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
mete
November 9, 2006, 10:05 PM
Protrusion ~ .060" ? Check firing pin and firing pin hole for burrs.Is firing pin and hole smooth or rough ?

rugerman
November 9, 2006, 10:13 PM
Felt smooth I'll check it again and measure the protrusion. thanks rugerman

Sunray
November 10, 2006, 01:27 AM
"...called brownells..." Whatever for? Call Savage. http://www.savagearms.com/contact.htm

rugerman
November 10, 2006, 10:32 PM
I called Savage first but since they changed hands since this rifle was made they were less than helpful, they wouldn't even give me a breakdown diagram of the bolt. They said that since they didn't recomend consumers taking it a part they don't give out that info. Not only would Brownells help they have the parts and real good service (I got the spring in 2 days). rugerman

Lee F
November 12, 2006, 08:07 PM
Two suggestions:

1. If possible check the headspace. Too much will result in light primer strikes.

2. Go over to Savage Shooters .com

rugerman
November 14, 2006, 10:03 PM
I don't think its a headspace problem but I'll check that out along with savage shooters.com. Thanks rugerman

rugerman
December 3, 2006, 09:58 PM
I think I figured it out, I removed the bolt and noticed the bolt release lever was kind of stiff so I lubed it inside and out and that seems to have fixed the problem, I won't know for sure til I have time to really spend some time shooting it but it looks good so far. Thanks for the advise. rugerman

If you enjoyed reading about "Savage 110 left hand .270 win. failure to fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!