Connector issues


PDA






BsChoy
November 17, 2006, 04:39 PM
I had my dept armorer put a scherer 3.5 connector in my G19 and I got it to the range today and every time I touched off a round the slide locked to the rear as if it was the last shot in the mag. I would then have to manually hit the slide release lever to shoot the next round?!?! Any input.

If you enjoyed reading about "Connector issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Desertscout
November 17, 2006, 05:43 PM
It has nothing to do with the connector. I would assume that when he put the slide stop back in it, he didn't ensure that the leg of the spring on the slide stop was UNDER the locking block pin. The locking block pin should be installed FIRST then the slide stop lever.

Navy joe
November 17, 2006, 09:30 PM
Concur, gun put back together wrong. Tell your armorer that he is now officially too dumb to breathe.

1911austin
November 17, 2006, 09:35 PM
A dumb armorer can really shorten the life expectancy of a good officer. There is no excuse for a duty weapon to be given back like that.

BsChoy
November 18, 2006, 03:59 PM
Wasn't my duty weapon...is my off duty we carry G22's with the 5lb connector

1911austin
November 19, 2006, 10:03 AM
Wasn't my duty weapon...is my off duty we carry G22's with the 5lb connector


I sure the heck would not let him work on my DUTY or OFF DUTY weapon.

btw: I am not a LEO

BsChoy
November 22, 2006, 11:04 PM
point taken my friend...I plan on giving him an ear full when next we talk.

If you enjoyed reading about "Connector issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!