Help S&W Models 4563TSW and 1006


PDA






TnMtnMan
November 27, 2006, 03:53 PM
I recently purchased a S&W 4563TSW and a S&W Model 1006.

I notice on both pistols that when you are shooting in single action, with the hammer cocked manually and starting to squeeze the trigger, about one third to halfway through the trigger pull there is a very noticeable "click" as if something is setting inside to fire. When you continue the trigger pull, the pistol will of course fire.

I own several firearms, including many S&W Pistols and don't have that feeling or click on others.

Is this perhaps something on newer pistol designs and if so, what is the purpose?

Thanks in advance,
Mike

If you enjoyed reading about "Help S&W Models 4563TSW and 1006" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Devonai
November 27, 2006, 04:25 PM
That's the magazine disconnect disengaging.

etech
November 27, 2006, 08:15 PM
It may be your "trigger play spring", a little u-shaped copper colored spring on top of the drawbar that puts tension on the trigger in SA mode. If it's not broke you can bend it slightly towards the front of the gun with the hammer down and the upper removed.

Gixerman1000
November 27, 2006, 08:29 PM
+1 = etech

The one on my 4506-1 has been broke for years but it's not a big deal, I may get it fixed one day since that spring is fine in all my other S&W autos.

If you enjoyed reading about "Help S&W Models 4563TSW and 1006" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!