remington model 11 problem


PDA






kam302
December 1, 2006, 01:42 PM
hi everyone I am new to the board. Well I have a remington model 11 16 gauge that has a bit of a weird problem. Well the gun has worked for the past 5 years an now when I Load shells in the gun it just spits them out. For some reason the shells dont lock in the gun anymore. Did something break? please help thanks kam.

If you enjoyed reading about "remington model 11 problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Chawbaccer
December 1, 2006, 04:19 PM
It wouldn't spit em out if the carrier was in the down position. Is it possible the carrier spring is broke?

kam302
December 2, 2006, 03:50 AM
when i load the shells into the mag tube they just keep on ejecting weather the bolt is cocked back or is closed. Also if the bolt is closed they will eject right under the latch between the bolt and latch getting stuck. please help.

Chawbaccer
December 2, 2006, 02:48 PM
Give this a look then. Press your bolt release button with the gun upside down and press the carrier as far as it goes. There is a slot in the middle of the carrier where there should be a cartridge stop protuding from the bolt up thru the carrier for about a quarter inch. Check and see if there is spring tension on the cartridge stop, I suspect the spring is broken or maybe there is a foreign object jamming the cartridge stop. Here is a link to a Browning A-5 schematic:http://www.e-gunparts.com/productschem.asp?chrMasterModel=0630zAUTO%205

If you enjoyed reading about "remington model 11 problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!