Lee LoadMaster Indexing Problem


PDA






bgddy58
January 13, 2007, 11:39 PM
It's been over 25 years since I last reloaded, but I think I remember the basics well enough. Recently I started shooting Cowboy Action, and realized that I needed to start reloading again to make this affordable. So I purchased a Lee LoadMaster press from Midway in December.

After I unpacked the press and installed it on my bench, I noticed that it wasn't indexing properly. The shell plate was not advancing when the handle was raised, and the index flipper was not moving in and out. I called Lee, and they recommended thet I first check the tail on the case ejector. I dod, and noticed that the "tail" was not bent as they recommended, so I bent the tail slightly.

They also recommended that I align the carrier. Simple enough, although I don't understand why the press didn't come already aligned. After alignment the shell plate did advance on each upstroke, but the press was very stiff to operate; especially in the middle of the upstroke.

But the remaining problem is that, while the shell plate advances, it advances to the wrong position. Each stroke rotates the shell plate approx 3/16" short of the proper position. With a spent case loaded, the shell plate advances the case off-center with the holes in the turret in all stations. For station 2, the case is off-center with the priming arm.

Did I do something wrong? Can I fix this? I really like the idea of an affordable progressive press, but I don't relish rebuilding ir from the ground up. Any suggestions?

BD

If you enjoyed reading about "Lee LoadMaster Indexing Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
bgddy58
January 13, 2007, 11:42 PM
Sorry for the duplicate post. Please respond to the previous (first) thread.

BD

If you enjoyed reading about "Lee LoadMaster Indexing Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!