Tikka Scope Rings Problem


PDA






Blondie
March 20, 2007, 09:39 PM
Hello All,

So I have a Tikka T3 Lite SS with the synthetic stock. When it is sighted in, its great.

But the recoil of the rifle seems to knock the rings around. Unlike my Remington 700, the rings attach to the top of the receiver by clamping on either side to the very top edge (the 700 has two bases then the rings attach to the base). Since they are clamps, they seem to get loose, and the scope slides forward or backward. I've seen everyone else speak great things about the T3, so I wanted to know if I have it set up wrong or if I'm just not tightening down the clamps good enough (I've tried tightening them down harder).

Regards

Blondie

If you enjoyed reading about "Tikka Scope Rings Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
zero_chances
March 20, 2007, 10:39 PM
Are the rings that are on it quality? If they are, try using a small amount of blue locktite.

hoghunting
March 20, 2007, 11:32 PM
You should see a small hole in the top of the receiver and a peg on the bottom of one of the rings. That peg goes into the hole and slide the ring as far forward as it will go. Tighten down the ring, then position the second ring and tighten it down. Then mount your scope. I also used blue Loktite on mine. My Tikka T3 factory rings are mounted on a 300 WSM and has had over 500 rounds fired through it. My scope or rings have not moved.

Fulcrum of Evil
March 20, 2007, 11:59 PM
I was looking at the T3s a while back - any opinions on them? Specifically, is it worthwhile to get the lite or are there significant improvements in the higher end versions?

atblis
March 21, 2007, 12:08 AM
Get a set of Warne rings.

atomchaser
March 21, 2007, 06:59 AM
I have a T3 and installed Burris Dovetail Signature rings. The factory rings seemed little light to me and I couldn't get my scope back far enough to get proper eye relief. You might try lapping the factory rings if you are going to use them.

Omaha-BeenGlockin
March 21, 2007, 12:07 PM
On my T3--I used Burris picatinny/weaver bases($16)--and then used Leupold QRW rings.

Screwed in --not clamped on---and detachable too.

BrainOnSigs
March 21, 2007, 01:04 PM
The rings that Tikka provided with my T3s were subpar IMHO. I have had very good success with Tikka OptiLocks. The Warne rings, mentioned by atblis, worked very well also. The Warne rings are less of a pain.

Blondie
March 21, 2007, 08:55 PM
Well the rings I am using are not the ones that came with the rifle. It came with stainless steel painted rings. I wanted black rings to match my scope. So I bought some black Tikka aftermarket rings from basspro for about $50. I think they are "quality," I just thought it was more of an issue of the design. I will look into getting that base set-up like someone mentioned. Thanks for the replies!

Blondie

Hokkmike
March 21, 2007, 09:02 PM
What hoghunting said +1. You have a fine rifle in my opinion.

whiskey
March 21, 2007, 09:06 PM
Loc-tite has kept mine steady since I first installed them.

If you enjoyed reading about "Tikka Scope Rings Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!