S&W 638 problems


PDA






Tango Sierra
June 19, 2003, 12:33 AM
Last week my son purchased a S&W 638 for a duty backup weapon. He immediately took it to the range and ran only 50 rounds through it due to time constraints. He said there were no problems.

A couple of days later I took it and fired 50 rounds through it and during the last 20 rounds the trigger would not re-set itself about five or six times without some help pushing the trigger forward the last 1/8 of an inch or so.

Yesterday he took it to the department range to qualify with it in order to be able to use it on duty. He fired 100 rounds and said the trigger failed to re-set two or three times.

Tonight I've been dry firing with snap caps and have found no pattern to the problem. The problem appears intermittently and does not seem to be limited to a particular cylinder chamber. Sometimes it may happen two or three times in a row and other times there may be twenty or thirty trigger pulls between a malfunction.

The trigger pull is the heaviest I've ever experienced on any revolver or pistol plus the cylinder gap is .006.

If returned to S&W what are the chances it will be repaired when the problem is so intermittent? Also will they be willing to do anything about the trigger pull weight and the cylinder gap under their warranty terms?

If you enjoyed reading about "S&W 638 problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
J Miller
June 19, 2003, 11:38 AM
This could be a case of needing a good internal cleaning.
You didn't say weather or not you have taken it apart and done that, so before sending it to S&W, I would recommend a good thorough cleaning and lubing.

Sometimes the factories will leave all sorts of junk inside guns. They also miss burrs and tool marks sometimes that will hang things up.

S&W revolvers are actually quite simple and easy to clean.
Once the side plate is off you can easily see how everything works together.

As for S&W and their warrenty I have heard good things, and have had negative resuslts myself, so I can't really comment.
The .006 b / c gap is probably within tollerences.

JMHO

FunYet
June 19, 2003, 04:16 PM
Exactly the trouble I posted regarding my 442 a couple of weeks ago. Only happened with live ammo and could not be duplicated with snap caps or dry firing. Gave it a very good cleaning but still had the problem. My 442 is at S&W at the moment, to address this problem. If I get any useful info I'll post it.

If you enjoyed reading about "S&W 638 problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!