Springfield Armory EMP problems


PDA






Biggums
June 8, 2007, 07:27 PM
Just got back from the range with my new EMP. The little gun had a bundle of feed problems when I fired PMC 115gr JHP's and several other brands of hollow points. I also brought a box of Remington 147gr match round nose rounds that all fired fine.

Upon close inspection of the fail to feeds I could clearly see the problem. The problem is with the Mec-Gar mags that come with the gun. As you load over 5 rounds you notice the 2nd round starting to nose dive under the top round. As the spring pressure builds at the 5th round the feed ramp must start pressing down and forward.

Why doesn't this happen with the round nose rounds? As I loaded those the 2nd round would dive but due to the round longer nose of the 147 grain bullet the dive was there but with the long nose it would still be able to find the feed ramp. With the 115 grain flatter hollow point at 5 rounds and more the 2nd round would start the dive and when releasing the slide the top round would also dive hard against the lower portion of the ramp making it impossible to feed. I tried a box of Black Talon hollow points in 115 grain and these would fail also.

I know there's a post on this site about a guy who bought 3 of these EMP's and was having the same problem. Readers suggested that this may of been a breaking issue etc.

I tried my second new mag with the same results.

This is a engineering problem with the mags and potential EMP buyers beware. Those who carry I would suggest trying some hollow points to see if you to have this problem. You can simply at home load some hollow points in the mag and see if after the 5th round the second round dips a little. I think the dip causes the first feed round to also dive when the slide starts pushing it and with the space of the second round there the first round goes down too. :fire:

Anyway I loved the feel of the gun and it seems deadly accurate but now I can't trust it. I also had a failure when the gun failed to extract a round. The slide was part the way back but I had to jack it back to get the case out.

For carry it's back to my Colt 1911's in 45.

I will be calling SA Monday morning. I would think they know about this.

If you enjoyed reading about "Springfield Armory EMP problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
tydephan
June 8, 2007, 07:34 PM
SA will make good on it. Give them a call. It sucks to send it back, but it happens.

Lots of problems with EMPs and JHP.

This thread has a good bit of info:
http://www.thehighroad.org/showthread.php?t=225870&highlight=EMP

DomMega
June 8, 2007, 07:54 PM
You know, I don't think Springfields like PMC ammo, period. I always had a problem with PMC in my XD40 and it would appear that the EMP is no different. By all means send it back to springfield, they'll take care of you, they always do. They'll probably just cut the barrel ramp and polish it but mine hasn't jammed since.

Best of Luck.

10-Ring
June 8, 2007, 08:01 PM
That really sucks...that little Springer made its way onto my wish list recently...I hate hearing/reading negative things about guns I want :(

Biggums
June 11, 2007, 08:48 PM
I called SA this morning and they treated me like a VIP. I got 2 calls back informing me on details of my gun return. My gun was one of the first run guns and they told me that the things I'm experiencing can and will be repaired easily.

I shipped it next day Fedex and John at SA told me he will be the one who works on the gun.

I feel condident this gun will be a winner with a little detail work. I can understand this can happen and have no problems with any of this. They are paying for the shipping of course.

I will be posting my range report as that time comes.

Thanks

Dave

If you enjoyed reading about "Springfield Armory EMP problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!