"Primer loader popping off press"


PDA






smokjunkee
June 29, 2007, 07:11 PM
Hello, Newbie question... I'm using a Lee 4-turret press & I have done a few hundred rounds. My problem is the primer loader(I'm using the Lee safety-prime), keeps popping off the press. Now this is a steel piece with a hole that holds a spring-loaded rod that holds the primer. This was happening when I was loading 9mm with a improperly tapped turret, so I thought that's why it was coming off. Now back to 38sp. & it has started to pop off almost every round.:fire: Anybody familiar with this set-up? Any tips or suggestions for me:fire? Thanks for any help.
SJ :fire

If you enjoyed reading about ""Primer loader popping off press"" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
wally
June 29, 2007, 09:56 PM
Mine did it initially. Look for burrs on the part of the primer arm that "hooks" around the cross pin in the ram.

Also, you have to install it with the shell holder removed and the ram up so it can get up and over the pin and then drop into proper position. The shell holder then keeps it from coming up and out.

HTH,
--wally.

Sistema1927
June 29, 2007, 09:57 PM
Hmmm, it took me a moment to figure out what was going on, but then realized that you are talking about the primer arm. Could it be that you have inserted it backwards? That is the only reason why I can think that it is falling out since when it is inserted correctly it snaps down in place where it rotates out to accept the new primer and then rolls into the proper position to seat the primer as the ram comes down.

st_albert
June 30, 2007, 12:52 PM
Well, I just took a look at mine, and I can't see how it is physically possible for the primer arm to come out of the ram with the shellholder in place. That, and the fact that you are unfamiliar with almost all of the proper names for the parts suggests to me that a more careful reading of the instruction manual or the helpful hints on the Lee website is in order. You almost certainly don't have it installed correctly.

Good luck,

Albert

benedict1
June 30, 2007, 01:53 PM
Remove shell holder; raise ram about two inches; insert PRIMER LEVER ARM and make sure the hook on the front of it intercepts the rod inside the ram; lower the ram and reinstall the shell holder. Go here to see how to properly set up your press and learn the names of the parts--this is from the Lee website on the page where the Classic Turret Press is described--

http://www.surplusrifle.com/reviews2006/leeturretpress/index.asp

smokjunkee
June 30, 2007, 08:24 PM
I'm sorry for the mis-use of terms. It's not the primer arm that is coming off the pin inside the ram but, the rod that holds the spring & cap is slipping out of the primer arm. I have since given it a slight tap with a hammer that seemed to widen the rods diamiter and it is holding for now. I don't think that I could have loaded over 300 rounds if it was installed improperly.
SJ

benedict1
June 30, 2007, 08:54 PM
Call Lee on Monday and tell them to send you a new one. Be sure to ask for either Pat or Dave, no one else. It is a warranty item and you should get one for no cost. Make certain you specify which size it is, small primer or large. I believe you are having trouble with the small one, right?

smokjunkee
June 30, 2007, 09:11 PM
Yes, the small one. Thanks, I'll call Lee on Monday.

strat81
July 2, 2007, 10:03 AM
Just to add, I swab a little CLP on the side of the arm (the piece that pivots inside the ram) to smooth it out.

benedict1
July 2, 2007, 02:03 PM
Not a good idea. The lever arm should run dry, even be cleaned with Gun Scrubber or Brakeeze. All the gunk that comes out of spent primers flows by the thing and any oil/grease there will cause a buildup and eventually it will stop moving freely. If you want to lube use powdered graphite only.

If the arm is sticking even when dry it may have a burr on it--polish the sides and edges with some steel wool or even a little emery paper.

strat81
July 3, 2007, 09:55 AM
Point taken, benedict, but CLP is very thin to begin with, completely different than say RemOil or something. Swabbing it on with a q-tip leaves even less. Maybe I haven't neglected my press to the point where it's building up. I regularly wipe it down and clean it off anyway since the auto disk has a tendency to "leak" powder.

If you enjoyed reading about ""Primer loader popping off press"" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!