AR-15 kit wobbles


PDA






DragonFire
July 19, 2007, 02:20 PM
I assembled my first AR15 from an Olympic Arms stripped lower and a upper kit from Model 1.1

All went well, and all the controls function as they should. But I noticed that there is a slight "wobble" to it. If I put a little side pressue on the pistol grip, the whole receiver seems to twist just a little bit. Not alot, but it is noticeable.

Is that normal?

The only area that I have any second thoughts on was when tightening the buffer tube (it's an A2 stock). I think I snugged up well, but I was worried but bending or otherwise hurting the receiver.

Should I tighten the tube? Any other probable causes/solutions?


FYI: It's 20" varmint flattop, SS heavy barrel. I have a 3-9x scope to mount on it.

If you enjoyed reading about "AR-15 kit wobbles" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
DnPRK
July 19, 2007, 02:31 PM
Go ahead and tighten the buffer tube. I've built a few an never had a problem with putting a cresect wrench on the flats and torquing away. If galling between the upper and tube is a concern, you can use a dab of anti-sieze.

The fit between some uppers and lowers will wobble. It doesn't effect accuracy because the bullet is out the muzzle before the wobble takes effect. "Accu-wedge" under the takedown lug or a thin o-ring around the takedown lug will minimize the wobble.

If you enjoyed reading about "AR-15 kit wobbles" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!