Problem with Taurus PT140MilPro. Please help.


PDA






03Shadowbob
August 19, 2007, 07:56 PM
I am copying and pasting this here as well as Taurusarmed.net just in case someone here has had this problem also.

Well, I have had my MilPro for almost a year now and have not had one problem ever until 5 rounds into shooting it today. I was shooting Winchester Ranger 155gr JHPs, not a +p round. After the 5th round fired, the recoil spring and plug went through the front of the slide. Now it did not fly all the way out but was stuck in the middle of the larger spring on the slide. I can not get it to push all the way through, one way of the other. I have a feeling the plug had been worn down somehow and it pushed through the end of the slide or the slide had a peening issue. I have shot about 600 rounds so far with it.
Has anyone else had this problem? How did you fix it? Have to send it back to Taurus (which I dread doing since their CS dept is terrible from the sounds of it)?
Any advice is greatly appreciated.
Thanks.

If you enjoyed reading about "Problem with Taurus PT140MilPro. Please help." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
wally
August 19, 2007, 08:10 PM
I believe junk it or send it back to Taurus for repair are your only two viable options. IF you are sure its just the plug that is broke you could call them and see if they'd just send the replacement part, but I've not heard of anyone having success with this -- they always seem to insist on wanting the gun back, but I am reporting hearsay as no personal experience with Taurus guns needing service.

--wally.

MPanova
August 19, 2007, 10:16 PM
Just give them a call and send it back. I believe I have heard this about the PT140 from a year ago, the new ones seem to not have this happen. I would just send it in and shoot something else for a few weeks till it comes back good as new ;)

People tend to complain about Taurus warrenty when they need to use it after a year and it takes a few weeks to get it back, but I guaranty you the same people will not complain if they have to send in 20 years from now and its fixed free of charge :neener:

I bought my wife a little PT22 with the pink grips and after getting a few feeding and extracting issues in the first 500 rounds or so I just sent it back to have them fix it, took 4 weeks and I hardly even noticed it was gone. I have 2 other 22lr guns I can shoot and one of them happens to be another PT22 that works just fine. After getting my wifes back it works just as good as my other one, as expected.

If you enjoyed reading about "Problem with Taurus PT140MilPro. Please help." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!