Ruger P95 Problem


August 26, 2007, 11:25 PM
Just got a new Ruger P95 this last week. One session shooting about 100 rds of WWB.
Had it home and dry firing on a spent cartridge with no mag in place.
Now the mags won't go in. They insert all but last inch or so. Looks like the ejector is interferring with mag right at the ejectors pivot point. What gives???

If you enjoyed reading about "Ruger P95 Problem" here in archive, you'll LOVE our community. Come join today for the full version!
August 26, 2007, 11:31 PM
You have the ejector pivoted down.

Pivot it back up.

2. With slide held upside down, replace barrel and push it rearward into its
locked position.
3. Replace camblock and recoil spring assembly into position. Rear end of camblock
seats against barrel lug.
4. Be certain that ejector is locked in its lower (forward) position and that
hammer is in its fired (uncocked) position.
5. Replace slide onto frame. Partially insert slide stop into frame.
6. Pull slide back until disassembly line on frame is aligned with disassembly
line on slide stop. Now push slide stop all the way through the frame to the
7. Allow slide to move fully forward.
8. Replace empty magazine in frame through butt of pistol. This action
returns the ejector to its working position. This pistol will not function
normally unless the ejector is in its upward (rearward) position

August 26, 2007, 11:34 PM
Ejector was in correct position

August 26, 2007, 11:35 PM
You didn't break it dry firing.

see also

August 26, 2007, 11:47 PM
WOW he did it exactly like I was doing.
This problem occured before I disassembled the pistol, however.

August 27, 2007, 12:15 AM
Are you still unable to insert the magazine?

August 27, 2007, 12:33 AM
Mags will not go in, due to apparent interference at the pivot point of ejector.
Other than that, gun seems to have all of it's functions working. Slide works. Cocks/decocks as it should. Can field strip and reassemble with no problems.Trigger works smoothly, just the damn magazines won't go in :banghead:

August 27, 2007, 08:47 AM
Call Ruger at (928)-778-6555, ask for product support and see what they have to say.

August 27, 2007, 12:26 PM
A call to Ruger, and a quick call back from a service tech resolved the problem (all of 10 min. total). The hammer pivot pin had "walked out". Pushed it back in, flush to the frame PROBLEM SOLVED!!!!!!!!!!!!!!!!:)

Ruger Service is GREAT!!!!!;)

August 27, 2007, 02:52 PM
I figured it would be something minor.

August 27, 2007, 03:07 PM
Now you need to figure out why your hammer pivot pin is "walking out."

I sure would hate to have the pin "walk out" on me at the wrong time.

August 27, 2007, 03:30 PM
a little dab of lock tite might do it. just be careful not to use too much.

August 27, 2007, 03:52 PM
that's strange...I've had my P95 (old version) since 2005 (as soon as the awb sunset) and I've shot thousands of rounds though it and never had it happen... as stated, probably a dab (use very can always add more later but can never take it back out ;) ) will hold it good :)

August 27, 2007, 04:20 PM
This was very easily visable (if you knew what to look for) as the end of the pin is an oblong piece that sets flush in a mating recess on the right side of the frame directly below the decocker pivot point. It had come out of the recess maybe 1/16", but clearly NOT flush.

The tech gave a reason why it did this, I just wasn't listening real well.:o

If you enjoyed reading about "Ruger P95 Problem" here in archive, you'll LOVE our community. Come join today for the full version!