Beretta 9000s 9mm jamming on cheaper ammo


PDA






Kindrox
August 29, 2007, 10:47 PM
I got a Beretta 9000s 9mm for the wife several months back but it has not gotten used until recently, as my wife practiced for her CHL and now has been shooting once a week after.

The first ammo we used as she practiced for her CHL was WWB 147 grain JHP, and 147 grain Blazer aluminum jacketed flat point. No jams or problems. On one session we tried Blazer 115 grain aluminum, and it caused problems. Since I knew it to be weak, I thought it was just related to weak ammo and a new, stiff spring. Turns out the same jam signature would show up again . . .

Her first few practice sessions after the CHL were again with the same ammo, but last week I had her try WWB 115ís, and some Chinese ammo, either 115 or 124 grain (not sure which). She reported problems last week and then again today, so today I went back with her to the range.

Using the cheap ammo, she fired about 40 shots and got about 4 fails. I shot about 25 rounds and got one fail. Part of my concern is the nature of the fails. Almost each time, the round is being pulled about half way out of the chamber, and then apparently the extractor is letting it go. Then the slide is getting hung up further back and then getting hung up on the round pushed up from the mag.

So after this, I opened a box of Fiocchi 147 grain FMJ, and between us had no fails out of the box of 50. Overall, out of about 200 147 grain shots, not a single fail from three brands of ammo. But consistent fails from three brands of 115 grain ammo.

I am failure with stove pipes, but not with the extractor letting go of the round. If you pop the clip after a fail, the slide slams shut, pushing the empty round back into the chamber.

Is this fail signature just from weak rounds compared to the slide spring? I have seen stove piping out of an uzi + weak rounds, but the extractor letting go of the round when the casing is half in the chamber seems very odd to me.

If you enjoyed reading about "Beretta 9000s 9mm jamming on cheaper ammo" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
wally
August 29, 2007, 10:59 PM
Check for dirt or oil in the chamber and crud accumulated under the extractor hook.

My wife has shot pretty much nothing but CCI 115gr Blazer aluminum cased ammo thru her 9000s.

--wally.

Kindrox
August 29, 2007, 11:17 PM
I don't think it is that, it has been cleaned multiple times and today it jammed on the 115 grain ammo then ran fine on 147.

That said, I have not actually taken the ejector off to get behind it, is that easy to do?

Mot45acp
August 31, 2007, 08:15 PM
I had one in .40. It was a POS from the get go. With cheap-o or expensive ammo and new mags I had every type of failure known to man (and even some new ones)
Traded problems disclosed at a loss.

Kindrox
August 31, 2007, 09:38 PM
Did you try sending it to Beretta? I have heard mixed reviews about that route.

If you enjoyed reading about "Beretta 9000s 9mm jamming on cheaper ammo" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!