Light primer strikes on SW40C


PDA






sel366
October 29, 2007, 02:01 AM
Hey guys, I got one of the Sigmas from CDNN this week (SW40C) it is LNIB and came with one mag for $199. I bought an extra high cap mag for $19.99. I new the reputation the older ones had before I ordered it. I shoot it with some aluminum cased 180gr FMJ this weekend. The first two rounds fired off fine, then came the light primer strikes. The indentations on the primers looked pretty weak. I tried the other mag and got the same thing.

I have used Blazer before in some of my other pistols with no problems. I am wondering if I need to try some different ammo or do I need to change out the striker spring. I have also heard Blazer has hard primers anyway. True? If that is the case then I will go with different ammo next time.

I have a newer generation SW40VE that is absolutely flawless and will eat anything that is fed to it. What say you THR's? Different ammo or change the spring? Is there another avenue that I need to go down? Thanks in advance.:)

If you enjoyed reading about "Light primer strikes on SW40C" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Grandpa Shooter
October 29, 2007, 03:35 PM
Makes more sense to check out other ammo than to start messing with the gun.

If you enjoyed reading about "Light primer strikes on SW40C" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!