New CZ75B issues


PDA






Blue .45
November 2, 2007, 08:57 PM
I'm disappointed to say, I'm having a little problem with my new 9mm CZ75B. I just bought this gun a week ago. When I took it to the range today, I experienced one stovepipe and twice the slide stop engaged while shooting. I'm sure my thumbs were nowhere near the slide stop when this occurred. The stovepipe happened while shooting 115gr. Winclean ammo and the slide stop issue happened while using 147gr. Federal, American Eagle TMJ. I shoot at an indoor range, so I have to use this stuff. My question is, can a bad slide stop cause both of these problems? and would a new slide stop likely correct these issues? Any suggestions will be appreciated.

If you enjoyed reading about "New CZ75B issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
SDDL-UP
November 2, 2007, 09:19 PM
Check for the nose of one of the 147gr. bullets hitting the inside of the slide stop. This can happen with some longer bullets with the correct profile. If this is happening you can file a little off until it clears. I don't know about the stovepipe.

armoredman
November 2, 2007, 09:37 PM
Did this happen with both magazines, or just one?

Blue .45
November 2, 2007, 10:29 PM
Did this happen with both magazines, or just one?

Actually, I'm not %100 sure which mag I was using when the stovepipe occurred. However, both times the slide stop engaged, it was with the same magazine, within about four rounds of each other.

Check for the nose of one of the 147gr. bullets hitting the inside of the slide stop. This can happen with some longer bullets with the correct profile. If this is happening you can file a little off until it clears.

I suspect that this is what is happening. I've heard of this occurring when a 9mm slide stop is inadvertently installed on the .40 cal version, but I didn't know this happened with the 9mm"s also. As this is a brand new gun, which I've had for only seven days, I'm reluctant to file on any of the parts, because I wouldn't want to do anything to void the warranty. I might give CZ a call monday to see if they'll send me a new slide stop. If that doesn't fix it, I might send it in to be fixed or return it to the gun shop for store credit or something.

The Lone Haranguer
November 2, 2007, 10:57 PM
The stovepipe happened while shooting 115gr. Winclean ammo ...
I don't know that I would worry about this ... yet. This is not the most powerful of ammo and may simply not have generated enough recoil to fully cycle the slide, when also combined with a new (tight) gun. Be sure it is clean and properly lubricated and shoot it some more with different brands. If it cycles properly with other ammo but not that brand, this is forgivable. ;) Any kind of consistent "stovepiping" is cause for repair.

TonyT
November 3, 2007, 08:00 AM
I have two CZ-75's - the standard and a single action. Both guns are extremely reliable with every reload I have fed them. I have never expereinced a single failure to feed, fire or function.

armoredman
November 3, 2007, 10:20 AM
Clean and lube thoroughly, disassemble and check magazine for function. Test fire again, keeping track which magazines have failures. If the same mag over and over fails, contact CZ-USA for replacement.

schmeky
November 3, 2007, 11:01 AM
tech4061,

Hang in there, don't give up on that 75, they are accurate and very comfortable to shoot. I have read many times CZ's were engineered to handle the really hot sub-machinegun 9mm rounds.

If those Winclean 115 grainers were not standard pressure ammo, this could definitely result in a stovepipe.

Lonestar49
November 3, 2007, 12:46 PM
...

Any gun, NIB, then to the range for the first time, goes thru some kind of break-in period. Some go 100% right out of the gate, others cough, now and then.

My bet is simply that she needs a complete cleaning, as they pack them with thick, long lasting, lubrication for protection from rust, as to ensure that in the time she leaves, to the time she is bought, no rust, corrosion, can occur.

It sounds like a case of "timing" that is not so much about 115gr vs 147gr, but rather a magazine issue, as it doesn't take much for some grit, to cause the timing to be off at a certain load-count, with that mag, or mags..

Clean both, the gun, rails, feed ramp, breach block, everything and put some fresh oil on her, along with, and most important, open up your mags, and clean them out, along with the springs, everything, and then use some kind of dry lubricate for the interior walls of the mags, and the springs.

EEZOX (a synthetic lube/*light-cleaner, in one) is great for your entire gun, but especially for the mags interior and spring, as it cleans, and then once wiped, you then put on a very very light coating of it on the interior walls and spring, let them sit for some 5 mins, as this stuff bonds to metal (it's all on the directions) and makes metal to metal contact slippery without attracting dust, dirt, and more important, powder residue..

It will not harm plastic and makes any of the plastic parts glide over metal far better, as well.

Keep us posted..


Ls

Blue .45
November 3, 2007, 07:29 PM
Thanks for the tips. I neglected to mention in my first post, this was my second trip to the range with tihs gun. I fired 150 rds. each trip for a total of 300 rounds. The slide locks occurred on the last magazine full. I did a basic field strip and cleaning prior to shooting each time. However, I didn't disassemble the magazines for cleaning. I really like this gun, so I'm going to make every effort to make sure it's %100. I'll try some of your suggestions and take it to the range again this week. Thanks again.

Daryl Licht
November 4, 2007, 12:48 AM
After acquiring CZ-75B's, both my son and I had a problem with premature slide lock early on. As it turned out, in both cases it was caused by the shooter. A little adjustment on thumb position cured it. If all else fails this is something to look out for.

Can't offer any help with the stovepipe, since neither pistol has had that problem in 3k or so rounds each.

Blue .45
November 4, 2007, 01:06 AM
Well, I field stripped the gun and cleaned it as best I could. However, I couldn't find instructions on how to remove the extractor for cleaning. When I disassembled the magazine, there was a considerable amount of thick oil in both of them. I cleaned those as well. Hopefully, I will be able to take it back to the range and try it again monday or tuesday.

Gary G23
November 4, 2007, 08:15 AM
I love my CZs. I currently own more CZs than any other brand of pistol. HOWEVER, IMO CZs require more "tweaking" to run correctly than anything else I've ever owned. I'm not bitching about it, but in my experience that has definitely been the case.

In all my CZs I put in a Wolff extractor spring, flatten the mag brake, change the sights, and check function with different weight recoil springs till I find the one that works best.

I had the premature slide lock problem with my 75B SA 9mm. I changed the mag springs, the slide stop, and the slide stop spring. The gun runs 100% now.

jmr40
November 4, 2007, 08:48 AM
CZ's are good guns, but I have read reports of some of them having issues with magazine springs as well as recoil springs. MIne ran great for a couple of years before the mag springs suddenly stopped functioning.

JDGray
November 4, 2007, 09:25 AM
I think I remember mine doing the early slide lock thing once when it was new. The stovepipe is almost always weak ammo or limp wrist.:)

Pilot
November 4, 2007, 12:55 PM
CZ's have a reputation for bein under sprung from the factory. I have a 75B and 75D PCR, while both were 100% out of the box, I still replaced the mag springs and recoil spring in both with higher power springs from Wolff.

Blue .45
November 7, 2007, 09:26 PM
Back with an update. After I disassembled and cleaned both my gun and magazines, I contacted CZ USA and spoke to a gunsmith about my slide lock issues. He told me to remove the slide stop spring to make sure it wasn’t bent. I removed the spring and made it as straight as I could. Today I returned the range with 200 rounds of ammo. I fired 100 rds. of Winclean ( 50rds 115 gr. & 50rds. 124 gr.) in addition to 100rds. of Federal American Eagle 124gr. TMJ. Also, I brought along a new Mec Gar 16rd mag in addition to the two factory ones. The slide locked prematurely five times. It happened at least once with every type of ammo I fired. I noticed that on every occasion, the top round was moved forward partially in the magazine, as though it were trying to feed. However, I’m not sure if this means anything. Tomorrow I will call CZ again to see if they will send me a new slide stop and spring. If not, then I’ll send it in for repair. BTW, I now have a total of 500rds. through this gun I’ll keep you posted.

Edited to add: I forgot to mention, it happened with all three magazines. The good news is, I didn't experience any stovepipe jams this time out.

If you enjoyed reading about "New CZ75B issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!