SIG question: normal wear and tear, or should I be concerned?


PDA






Crow1108
November 12, 2007, 07:31 PM
Purchased a used Sig P229 a few months back, and have put maybe 600-800 rounds through it since. My concern is after a trip to the range yesterday, I broke it down to clean it, and noticed the rails (on both sides) are getting a little chewed up towards the back (above the decocking lever).

It isn't VERY significant, but it is pretty rough, and can be seen with the naked eye. It's one of the older, non-railed variants. Is there anything I can do to remedy this, or is it something to be expected? I keep the rails pretty well oiled, and clean it after every range trip (about once a month).

I'll try to take some pics of it tomorrow and post them on here.

If you enjoyed reading about "SIG question: normal wear and tear, or should I be concerned?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Crow1108
November 18, 2007, 03:23 AM
Sorry it took so long. Been busy with work and whatnot. Here are the pics. I circled the areas on the frame that I had questions about. Thanks in advance.

The Lone Haranguer
November 18, 2007, 09:43 AM
I have a P228. It shows a little burnishing (the anodizing worn off and slight corner rounding) in that area, but no burring or ragged edges like yours. But it also fires a milder cartridge and has a lighter (and possibly softer steel) slide. Other SIG owners, especially those with Nitron-finished slides, have reported wear like this but had no problems because of it. My guess would be that it gets to a certain point and stops. I do prefer to use a grease (e.g., Tetra, TW25B) on the frame rails.

Crow1108
November 18, 2007, 02:51 PM
Thank you very much.

rcmodel
November 18, 2007, 03:10 PM
It appears to be galding due to lack of proper lubrication.

Try using some good grease instead of whatever light oil you have been using.

If it continues to get worse with grease, I think a trip back to SIG might be in order.

http://i81.photobucket.com/albums/j219/rcmodel/KTOG/1224.gif
rcmodel

Crow1108
November 18, 2007, 08:02 PM
Been using CLP on it. I'll get some grease next time I'm out. Thanks alot for the advice.

If you enjoyed reading about "SIG question: normal wear and tear, or should I be concerned?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!