Yugo AK problem?


PDA






trbon8r
March 19, 2008, 11:39 PM
I took my Yugo AK underfolder for its first shoot today. When I got home and took it apart for cleaning I noticed that the little plug on the very end of the recoil spring was sitting sort of cockeyed off to the side. I figured that wasn't good, and tried to move the plug/cap/button or whatever its called to where it was centered in line with the spring and would evenly engage the spring. Unfortunately as I tried to adjust the whole mess to get it lined up, the hooks from the guide rod that engage the little plug came out. Now the spring is totally disengaged and I'm having a hell of a time trying to get the spring compressed and back on the spring guide so I can try to put the little plug back on. I hope this all makes sense. :o

Is there a trick to trying to reassemble this whole mess? It's almost like I'm spinning my wheels unless I have some sort of tool that will compress the spring while I get everything lined up. Basically it's like trying to put toothpaste back in the tube.

If you enjoyed reading about "Yugo AK problem?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
nalioth
March 20, 2008, 11:21 AM
Push the spring back on the guide rod all the way down past the top section. Once you get the spring all the way past the joint, bend the top section at a 90 degree angle and replace your button.

It doesn't matter if it's cockeyed, it ain't going anywhere.

If you enjoyed reading about "Yugo AK problem?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!