Uberti 1866 - Clunky Lever


PDA






BobbyQuickdraw
March 21, 2008, 03:09 PM
I just got my Uberti 1866 the other day and took it apart for cleaning/strengthening the loading gate. It was a bit of a hassle!

Now its back together, minus the loading gate which has the JB Weld drying on it.

I worked the lever and everything seems to be moving in the right direction, however, it doesn't seem quite as smooth as it did before I took it apart and put it back together.

Anyone know what might cause this? It may just be my imagination, but I dont know. Screws too tight? Not tight enough? Lever spring shifted?

Specific to 1866 - does the lever spring that rides the lifter sit in the notch on the lifter, or behind the notch? Its like a small rounded/cut down area.

Also, there seems to be a bit of play side to side with the lever, the lever screw is tight. Is this just normal for a lever action? I'd say it might be 1/4in either director at the back of the lever, but it doesnt seem to be shifting at the hinge.

Again, I could just be babying a new rifle and I don't have much experience at all with lever actions.

And for those who dont know - Uberti doesn't have instruction manuals for take down/build/ etc!

Any help is greatly appreciated.

If you enjoyed reading about "Uberti 1866 - Clunky Lever" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
dfariswheel
March 21, 2008, 08:04 PM
Try adjusting the tension screw on the lower tang.
There's two screws. One big one is the screw that holds the mainspring, the other puts tension on the spring.
By turning the spring in slightly, the tension on the hammer gets lighter, and the action gets easier to operate.

Some wobble in the lever is normal.

If you enjoyed reading about "Uberti 1866 - Clunky Lever" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!