Ruger P345 - Magazine fails to eject


PDA






scalper
April 5, 2008, 12:26 AM
Hey y'all have any ideas what might be wrong with my P345? I am completely at a loss. I just finished cleaning the gun, put it back together, and then popped a magazine in. Everything functioned okay as near as I could tell, but when I pressed the mag release button, nothin happened (it wouldn't eject like it is supposed to). And I can't tear it down with the magazine in, so I have no idea what is wrong. This is really weird and it is driving me crazy. :banghead::banghead:

Heres to hoping that some of my ole buddies on THR have some ideas. I hate the idea of having to ship it to Ruger for something that might be a simple fix.

If you enjoyed reading about "Ruger P345 - Magazine fails to eject" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Rayden
April 5, 2008, 02:13 AM
Sorry that has never happened to me.

novaDAK
April 5, 2008, 03:55 AM
Check to see if it will lock the slide back when the mag is empty (with mag inserted, pull slide back) if it doesnt lock back, odds are, you have a problem with the magazine follower, since it uses the tension of the mag spring against the slide stop to eject the magazine.

I had a similar issue when I bought a cheap gunshow magazine for my P95. It was missing the tab on the side of the follower so it wouldn't engage the slide stop. Wouldn't lock the slide back and wouldn't eject mag from the gun.

scalper
April 5, 2008, 10:32 AM
Thanks novaDAK. The slide will lock back. But, this gun has been quirky from the start (last Sept). Lots of inconsistent behaviors, so I think I am going to have to send it in to Ruger. Hopefully, it won't cost me anything (other than postage, ugh).

This is the only Ruger I have ever owned and it has been a bit of a headache. I hope they can help me iron out the problems on this, since all my buds told me how great Ruger is (I own 3 Tauruses with 0 problems), this will certainly be the test for me.

I guess Rugers do break after all. LOL

Shear_stress
April 5, 2008, 12:42 PM
Maybe the magazine follower over rode the slide stop and is hung up on it. Has happened to me before.

scalper
April 5, 2008, 01:18 PM
Maybe the magazine follower over rode the slide stop and is hung up on it. Has happened to me before.

So if that were the case, any idea how to fix?

Shear_stress
April 5, 2008, 04:40 PM
If you're able to pull back the slide far enough to reach the takedown position, you might be able to wiggle the slidestop lever out far enough to free it from the mag follower.

jhoff8487
April 5, 2008, 06:44 PM
There is a hole with a peg in it...that'll make more sense looking at your gun...on the side that ejects the shells. This hole/peg is to the left of your serial # plate at the top of the grip. Ensure that is pressed fully into the notch and seated. My P345 had the magazines so they wouldn't really drop out and had to be pulled, I noticed that, pushed it back in, and it worked fine. Mine did it after about 250 rounds through the gun. I've put another 2000+ and haven't ever had the problem again. Hopefully that works for you.

scalper
April 6, 2008, 12:15 AM
There is a hole with a peg in it...that'll make more sense looking at your gun...on the side that ejects the shells. This hole/peg is to the left of your serial # plate at the top of the grip. Ensure that is pressed fully into the notch and seated. My P345 had the magazines so they wouldn't really drop out and had to be pulled, I noticed that, pushed it back in, and it worked fine. Mine did it after about 250 rounds through the gun. I've put another 2000+ and haven't ever had the problem again. Hopefully that works for you.

JHOFF8487, thanks a million. That worked perfectly. I was actually getting ready to ship it off to service. I am glad I read your post. The peg was really difficult to turn, but eventually it did and when it did works just fine. Thanks again. You are a miracle worker.:D:D:D

tommet
August 22, 2011, 03:14 PM
Dang, was gonna post the solution, as I didn't see it in google. Already posted. So deleted. Apologies for bumping the thread.

If you enjoyed reading about "Ruger P345 - Magazine fails to eject" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!