Search


PDA






Derek Zeanah
April 18, 2008, 01:29 AM
OK folks, we should be able to search for 2 letter words now.

Server load will be a bit higher, and if it turns out it's too high this way we'll need to make more changes (turn off boolean searching, reevaluate search priorities, etc).

Anyway, I hope it gets less complaints now anyway.

If you enjoyed reading about "Search" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
gravis86
April 18, 2008, 01:40 AM
Thanks! Now I'll be able to search "WA" in the classifieds like I've wanted to for so long.

Dksimon
April 18, 2008, 01:59 AM
Thanks, that was also much quicker than I anticipated
Great work maintaining a great website!

yongxingfreesty
April 18, 2008, 02:00 AM
The search term you specified (tx) is under the minimum word length (3) and therefore will not be found. Please make this term longer.
If this term contains a wildcard, please make this term more specific.

Evil Monkey
April 18, 2008, 02:02 AM
same here searching for "223 ak"

"The search term you specified (ak) is under the minimum word length (3) and therefore will not be found. Please make this term longer.

If this term contains a wildcard, please make this term more specific."

Derek Zeanah
April 18, 2008, 08:55 AM
223 ak (without any quotes in the search field) got me 233 pages of results.

Is that how you searched?

BryanP
April 18, 2008, 08:57 AM
"The search term you specified (cz) is under the minimum word length (3) and therefore will not be found. Please make this term longer.

If this term contains a wildcard, please make this term more specific."

Derek Zeanah
April 18, 2008, 08:57 AM
A quick check showed boolean searching wasn't enabled for me, but it was for regular users. I went ahead and turned that off -- let's see if that helps.

Derek Zeanah
April 18, 2008, 09:00 AM
There was one more spot where I needed to change minimum search length. Should be working now. :)

Derek Zeanah
April 18, 2008, 11:44 AM
3 hours without comment. Does this mean the new search function is working for everyone?

Mal H
April 18, 2008, 12:29 PM
It's working, but not the way it should. For example, yesterday a member was having difficulty using ".41 magnum" as keywords. I just tried it and the search results contains the word "magnum", but not "41". I tried it with and without parens. I tried .357 magnum as well and got similar results. Since Boolean searches are disabled, it seems the default is 'OR' rather than 'AND' as should be the case.

Samuel Adams
April 18, 2008, 01:10 PM
CZ works for me.

Derek Zeanah
April 18, 2008, 01:39 PM
So boolean needs to be back on then?

edit:just tried .357 magnum (no quotes at all) and it looks like it worked fine for me. Checked the first 4 hits and saw .357 and magnum highlit even if they were the only words in the post, but there was always one post or more with the words together as you'd expect.

I guess I need to try some searches but have the results display as posts rather than threads. Probably won't be today or tomorrow, but may have time on Sunday...

Mal H
April 18, 2008, 01:49 PM
I was searching for results as posts not threads. Maybe that makes a difference, but it shouldn't. If there are two words in a search parameter, only posts containing both words should be returned. IOW, in general AND should always be the default.

Evil Monkey
April 18, 2008, 01:49 PM
223 ak (without any quotes in the search field) got me 233 pages of results.

Is that how you searched?

Yes, that's how I searched, without quotes. I just tried it again and it works.

Derek Zeanah
April 18, 2008, 04:31 PM
OK Mal, try again. Boolean searching is enabled for registered users now.

Mal H
April 18, 2008, 05:55 PM
I don't know, Derek, maybe the search engine and I disagree on what the returned results should be.

I entered 357 AND magnum (the AND was included and not included, same results) and got 807 hits in revolvers for the past month. This thread is a good example of why I think the search failed: http://www.thehighroad.org/showthread.php?p=4415691&highlight=357+magnum#post4415691

Note that "357" was found, but not "magnum" (even though 357 wasn't highlighted, but that's a different and unimportant issue). IOW, the Boolean "OR" is still the default.

If I enter two search arguments, I expect those two to be present in the list of posts returned. If the they are in the thread, then it is working, but not very well. As it stands now, I would say the search isn't working for multiple search arguments.

Derek Zeanah
April 18, 2008, 06:52 PM
Try it one more time Mal -- you and I aren't in the registered users group, but now we're boolean too. ;)

Mal H
April 18, 2008, 08:35 PM
Alright! Now it's returning expected results.

Thanks much, Derek.

dwave
April 18, 2008, 09:30 PM
Thanks! Its nice to be able to search by caliber again. :cool:

MikePGS
April 21, 2008, 10:21 PM
Just noticed you can search the for sale forum's by state again. Thanks as always for all of your hard work Derek, it's much appreciated.

ronnyreagan
April 24, 2008, 02:23 PM
Just wanted to chime in with thanks. Searching the Trading Post by state makes things real easy.

If you enjoyed reading about "Search" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!