Inaccessable last page?


PDA






ctdonath
June 16, 2008, 10:51 AM
For some time now, sporadic threads won't let me go to the last page. Ex.: for thread http://thehighroad.org/showthread.php?t=367828&page=4 on page 4 of 5, and click 5, >, 'latest posts', edit the URL with "page=5", etc. and it takes me to page 4.

If you enjoyed reading about "Inaccessable last page?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
ArfinGreebly
June 16, 2008, 11:08 AM
It's evidently a vBulletin quirk, related to soft-deletes or something of that kind.

Mods often go into threads and soft-delete stuff that's "all noise, no signal" or posts with offensive content. The post is still there, mods can still access it, but to the world at large it's gone.

We've had other reports of "ghost second pages" in this context, and we've looked into it before with the admin types but, until some kind of fix works its way into the code, we just live with it.

It's relatively harmless, even if it is occasionally a nuisance.

JShirley
June 16, 2008, 11:09 AM
Carl,

If you go to your User CP, and hit "Edit Options", how many posts per page are you set for? I'm set for 40, and I don't even get a 4th page.

Robert Hairless
June 16, 2008, 11:20 AM
I have no trouble getting to page 5 after clicking on Carl's link but I experience a different anomaly on pp. 4 and 5.

Where I usually see "Welcome, Robert Hairless," last visit, and so on, the linked page and the next page display the login box. That's after I get to the thread by clicking on his link.

When I enter the thread by clicking on it from the list of threads, everything is normal.

Mal H
June 16, 2008, 11:50 AM
Robert - what you described is a different problem, and one that arises because some members use different URL's to access THR.

If a link goes to "http://thehighroad.org...." and you logged in at http://www.thehighroad.org", or vice versa, you will get the login-again issue when you access the link. What I do in that case is simply add "www" to (or delete it from) the link in the address bar and I don't have to login again (creating an extra THR cookie).

It's just a quirk caused by having two usable URL's. See if that isn't true in the case you cited.

Robert Hairless
June 16, 2008, 01:21 PM
I see. I now understand the logic, Mal. That's in fact what's happening. Thank you.

If you enjoyed reading about "Inaccessable last page?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!