High Standard Supermatic 12ga feeding issue


PDA






TurboThom
August 24, 2008, 08:31 AM
I am having some problems with a shotgun I got from my father when I started hunting. The gun has been stored for two years, and I pulled it out for wild turkey season. I disassembled it as far as I am comfortable with, pulling the bolt and trigger housing, so I could give it a good cleaning. After reassembling, I took it to the range to pattern it.

I loaded it with winchester 2 3/4" trap loads to start off with before moving on to turkey loads, closed the action, and fired. Every two to three rounds, the action would lock open without feeding another shell from the tube magazine. It seems like the action isn't being blown back far enough to hit the latch and release a round from the tube.

It's gas operated from what I gather, so is there a port I can clean out? I'm not sure how to disassemble it past removing the bolt and trigger group. Could the loads be too weak to cycle the action? I didn't try anything heavier, since I was having problems with the trap loads.

Thanks for reading, and I appreciate any advice you can give me. I'd love to remove this gun from safe-queen status. I can post pictures if they'd help.

If you enjoyed reading about "High Standard Supermatic 12ga feeding issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
If you enjoyed reading about "High Standard Supermatic 12ga feeding issue" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!