Polytech M14 rear windage not working...


PDA






D-Day
September 6, 2008, 12:09 PM
Well, I just picked this up at a gun show and I'm already thinking about getting rid of it. The rear windage does not work. For some reason it's all the way to the left, and it won't go back to the right. Anybody know what the problem is? I really don't wanna strip it unless I know what I'm looking for. Not to mention the front sight is as loose as a goose and needs to be tightened. Apparently it doesn't have more than a 100 or so rounds through it; gee, I wonder why.

I knew what I was getting into, being a Polytech, but I couldn't pass it up for the price...I got it for a decent deal, but I'm thinking of getting rid of it already. Other deals were at the gun show, and there would be no love lost for this one.

If you enjoyed reading about "Polytech M14 rear windage not working..." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
H2O MAN
September 6, 2008, 12:17 PM
Some of the ChiCom rear sights are not so good, consider swapping it out for a nice USGI rear sight assembly.

D-Day
September 6, 2008, 12:31 PM
Well, I'd kinda rather have something else now. I couldn't pass it up for the price, so I simply may pass it on. If I really wanted to keep it, I'd swap out the sights, bolt, etc. but it's not worth it to me.

Ash
September 6, 2008, 01:53 PM
I have seen many of the Chicoms with crappy rear sights. Sometimes I have seen the receivers with detents too shallow to be of any use. It may not matter if you plan on using optics, but it means iron sights are fundamentally useless without work on a great many.

Ash

If you enjoyed reading about "Polytech M14 rear windage not working..." here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!