Ruger 77 MKII extracter problems


PDA






Rokman
September 8, 2008, 07:06 PM
I have three of these rifles that were purchased by my dad in 1996 and two of them (.30-06 and .22-250) work perfectly. I broke out the .223 rifle and shot it for the first time this past weekend. I immediately noticed that it didn't want to extract the spent cases. It would usually just pull them out of the chamber and drop them without ejecting them. The owners manual says to clean the face of the bolt and check for debris under the extractor. I checked it out and thoroughly cleaned it. It will now clear some of the cases if I rack the bolt really hard. Ruger wants to sell me an extracter or send it in. Any ideas or suggestions please.

If you enjoyed reading about "Ruger 77 MKII extracter problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
shinz
October 4, 2008, 04:53 AM
Being checking thru some old posts since I joined & wondered how you'd got on with this. It occurs to me the fault might be with the ejector rather than the extractor. The smaller case requires the ejector to rise higher than in the bigger cased rifles, I don't know if this are spring loaded or get "kicked" up by the action of the bolt, but I'm picking the ejector might be gummed up & sticking or similar& so not rising far enough to connect with the cartridge rim. Worth checking out.
Steve

If you enjoyed reading about "Ruger 77 MKII extracter problems" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!