Savage Model 14 Bolt FTE's


PDA






General Disarray
October 15, 2008, 03:06 AM
Man, I'm having a great week with rifles. :rolleyes:

My Savage Model 14 isn't ejecting spent rounds when I pull the bolt back, but the extractor is letting them go and they're staying in the chamber. I read somewhere that disassembling a Savage bolt requires a gunsmith to reassemble because unlike Winchester 70's and Rem 700's the Savage bolt must have the firing pin protrusion adjusted upon reassembly. Is this not something I can accomplish on my own? I'm guessing the extractor and ejector needs a good cleaning, but I've never taken one apart so I don't know what to expect in there. Any help is appreciated.

If you enjoyed reading about "Savage Model 14 Bolt FTE's" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
skinewmexico
October 15, 2008, 11:07 AM
A gunsmith? Nothing on a Savage needs a gunsmith. You can take it apart in 2 minutes. There is a sticky somewhere on Savageshooters.com with pictures.

And now that I've thought about it, you don't even have to take the bolt apart to do it. Just put it in a plastic bag, and slide the extractor in, and it comes off the detent ball. Savage makes a steel extractor that solves a lot of these problems. I think you drive a pin out to remove the ejector. Sharpshooter Supply can answer questions, and sells parts.

General Disarray
October 15, 2008, 06:45 PM
Thanks man. I wonder why that blog I was reading specifically made that distinction between Savage's and the rest of the lot. Weird. I can't quite picture what you mean by the plastic bag trick, but it's probably time for this bolt to get a good scrubbing down anyways, so I'm going to just break the whole thing down. I just wanted to make sure first. Thanks.

skinewmexico
October 15, 2008, 09:32 PM
Lots of people hate Savages. Get a big plastic bag and take it apart inside it, so if something flies off, the bag catches it.

General Disarray
October 17, 2008, 07:17 PM
So I tried to take down this bolt, and I couldn't get the alum wrench to budge the nut on the back of it. I sprayed some wd-40 and it still won't budge. I've now stripped the wrench. Is this supposed to be this difficult, and should I tighten it down like this once I reassemble it?

skinewmexico
October 18, 2008, 01:16 AM
I'm lost now without pictures. You didn't need to take the bolt apart to take the extractor off. Did you go look at the bolt dissamebly sticky on Savageshooters?

If you enjoyed reading about "Savage Model 14 Bolt FTE's" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!