New AK, old problem?


PDA






Aka Zero
November 19, 2008, 09:01 AM
Just got my first AK, and and saiga ( the pretty one I really wanted)

Ak it a wasr 10/63 got it NIB from classic arms before they sold out in about.... hours. It has the galil foregrip and adjustable stock.

I made the mistake of taking out the cleaning rod, now it won't go back. Is this a common problem, I see a lot of pictures of AK sans the rod, But I want it there. Once it goes in, it shall stay.

Gets to where it needs about 3/8" more in, before it will click into the appropriate place.


And side note. Saiga is 100% better than the wasr, fit finish and everything. Bought the thumb hole stock, slant cut receiver. (not planning on converting, it's to pretty anyway) If you can find them.

If you enjoyed reading about "New AK, old problem?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
jackstinson
November 19, 2008, 09:32 AM
Pull the lower hand guard off and check to see if the rod is catching on something down at it's lower end. I have heard of some WASR's with that exact rod issue having an errant bit of metal in there which snags the rod sometimes. It may be that fitting the Galil type guard affects this also.
My WASR GP 10/63's rod pops in and out just fine, but it has the standard laminated wood set-up.

Aka Zero
November 19, 2008, 11:31 AM
Finally figured it out. Rod isn't perfectly straight, son i had to squeeze between the foregrip and bayonet lug to get it to flex that tiny bit into place.

Oh well, I have a cleaning rod, and a boresnake for cleaning anyway.

If you enjoyed reading about "New AK, old problem?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!