my new AK drum isn't working


PDA






coosbaycreep
November 19, 2008, 07:56 PM
http://img20.imageshack.us/img20/6631/cars587oy6.th.jpg (http://img20.imageshack.us/my.php?image=cars587oy6.jpg)http://img20.imageshack.us/images/thpix.gif (http://g.imageshack.us/thpix.php)

I just got a new Romanian 75rd. AK drum from cope's, and today's the first time I got to use it. I loaded 75 rounds in it, then started shooting, and I only got about 5 shots off before the gun stopped. The drum didn't push the next round up far enough to feed. I messed with it for quite some time, pushing on the lever, shaking it, turning the gun upside down, etc., and it never did feed a second round the rest of the day.

I pulled the cover off, and I don't see what could be messing up on it. I do believe this drum is new too. There just doesn't seem to be enough pressure to push the rounds up far enough to feed.

Any suggestions on how to fix it? I'd really prefer to not have to try and get a refund, but I don't want a $125 paperweight either.

If you enjoyed reading about "my new AK drum isn't working" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
PTK
November 19, 2008, 07:58 PM
Did you load it right? You have to load those a certain way to get proper spring tension for feeding. ;)

coosbaycreep
November 19, 2008, 08:31 PM
hmm

I thought I loaded it right, but if I didn't, it certainly wouldn't be the first time I screwed something up.

I worked the lever thing for each round I loaded, but every 5 or 6 rounds it would get real difficult to load, so I would push the lever however many times it took to get the rest of the rounds down where it was easy to load again. That's probably what happened then. I'll have to try it out again and see if it's my fault then. Thanks.

GrandmasterB
November 20, 2008, 01:48 PM
Here's a tutorial for loading a Chinese drum. Not sure if the Romanian loads the same way, but it might help. http://www.gunsnet.net/Linx310/chinesedrum.htm

Prince Yamato
November 20, 2008, 02:28 PM
I pulled the cover off, and I don't see what could be messing up on it. I do believe this drum is new too. There just doesn't seem to be enough pressure to push the rounds up far enough to feed.

Umm... the covers aren't supposed to come off the Romanian drums...

DrewH
November 20, 2008, 02:50 PM
You can take the cover off a Romanian drum easily enough. You don't take them off to load them, sure.

When I loaded mine I just pressed on the lever for each catridge, so double check the loading procedure. Might have to check and adjust spring tension inside the drum, sorry I don't remember how. Be careful, lots of sharp edges inside the drum.

teflonbilly0
November 20, 2008, 04:20 PM
First off, be very careful as those drums will eat your fingers. But the solution seems to be quite simple. You need to "wind up" the drum. It is my understanding that the drums are stored without much tension on the springs so you need to open up the back and turn the mechanism till its tighter.

I recomend never actually sticking your hands inside the drum. I use a screwdriver to turn mine.

CSestp
November 20, 2008, 04:33 PM
First off, be very careful as those drums will eat your fingers.

Sound like you have some form of first hand knowledge of this.

coosbaycreep
November 20, 2008, 05:26 PM
thanks for the replies

I was messing around with it again last night, and now I don't know how to put the follower back wherever it's suppose to go. Can one of you post a pic of a drum with the cover off and the follower in place for me? Or if there's a website somewhere that shows a picture of it? thanks.

teflonbilly0
November 21, 2008, 12:08 AM
I had some ammo in one when it went all crazy, and it chipped the steel casings. Scary. :what:

Here is a link to a bad pic. The "wheels" should push the follower up as shown.
http://img337.imageshack.us/img337/5909/magfolloweriiiqm8.jpg


GL!

RaisedByWolves
November 21, 2008, 03:11 AM
Fiero??



!st, open it up and clean ALL of the grease and oil out with carb/brake/gun cleaner and lightly oil the works.


Heres some close ups. I was told to pre set the tension to 3 turns, but Im sceptical. I Have mine tensioned 3 bays and it seems OK. That is 3 bays of the pinwheel.




http://img134.imageshack.us/img134/6387/dsc02821wq5.jpg



http://img134.imageshack.us/img134/741/dsc02820hv9.jpg

coosbaycreep
November 21, 2008, 08:11 PM
Sharp eye Raisedbywolves, that is a fiero. How ironic is it that my car is potentially more deadly than an
AK-47?

I'm going to try and get my drum cleaned up properly and put back together tonight, then hopefully test it out this weekend or next good day without rain. Thanks for all the pics/info.

RaisedByWolves
November 25, 2008, 03:25 AM
LOL, I think having an AK in that car is illegal in 37.5 states.


Black Fieros are illegal in NJ and Cali.......




Seroiusly though, just play with the tension (Watcher fingers) and it will come to work. Let us know how you like it, wheighs a ton fully loaded.

If you enjoyed reading about "my new AK drum isn't working" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!