PPK failing to lock back on empty mag


PDA






The Wiry Irishman
February 25, 2009, 11:44 PM
I have an Interarms PPK that I've put somewhere in the vicinity of 1000 rounds through. For most of the time I've had it, the internal slide stop engaged on an empty mag. Recently it has stopped doing this. It still runs reliably, and upon playing with it, there's a 16th, maybe an 8th of an inch of slide travel between when the slide can strip another round off the magazine and when the slide stop engages, so I'm assuming that the slide is no longer coming back all the way.

Any ideas about what could be causing this? The only things that have changed physically with the gun are a quick polish of the feed ramp and a noticeable decrease in the strength of the recoil spring. The previous owner said he had about 400 rounds through the gun, bring the total on this spring to 1400 or so - how long are these springs supposed to last, and is there any way a weak recoil spring could cause the slide to not come all the way back? I would think that it would be just the opposite, that it would make it easier to come back all the way. Its not a weak mag spring, I just bought two new ones that have the same problem. I don't think its ammo, either, as I've run everything from WWB to hot SD loads through it, and if I remember correctly, it was locking back on WWB when I first got it. I was lubing with Slide Glide, and wondered if that was too viscous, so I tried running it soaked in CLP as well as with a minimal amount of CLP and the problem persists. About the only lube option I haven't tried is just slathering it in Slide Glide. I'm not limpwristing either, if you limpwrist this gun it will fail to feed.

Now that I think about it... Is it possible that a weakened recoil spring could cause the slide to move back too quickly, bouncing off its rearmost position and coming forward before the follower is high enough up to engage the slide stop? Since the gun doesn't strip another round off the mag until 1/16 - 1/8" forward of where the stop engages, that could be enough time for the follower to pop up another round so it still feeds and fires reliably.

Any input would be appreciated. Thank you.

ETA: Upon re-reading I found my wording might give the impression that the slide does not lock back at all. When I insert an empty mag and manually pull the slide back it works fine. The problem occurs when firing the gun.

If you enjoyed reading about "PPK failing to lock back on empty mag" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
wrc376
February 25, 2009, 11:49 PM
my first thought was a weak mag spring or bunk ammo

usp9
February 26, 2009, 06:33 AM
Any noticable wear on the slide catch bar when you remove the slide? Are the followers worn?

The recoil spring and timing issue could well be the cause. Springs are cheap, I suggest you try a new one and see if it helps. FWIW, In my experience changing the recoil spring on a PPK can make reinstalling the slide frustrating the first couple times as there doesn't seem to be enough room for the new spring. It's tight, but it fits.

The Wiry Irishman
February 26, 2009, 10:36 AM
No wear is visible on the slide catch bar, and the followers look brand new. However, there is a little bit of gunk between the slide catch bar and its cutout in the frame near where it pivots. I'm going to hose that out and see if the grit was slowing down the catch's movement and order some new springs.

David E
February 26, 2009, 10:53 AM
1) The mag spring is weak or dirty.

2) The internal slide stop is dirty.

3) A combination of #1 and #2


It's probably locking open with an empty mag because you're pulling the slide back SLOWER than it comes back under recoil. This gives a weaker mag spring and/or dirty slide stop more time to get into the proper position. Try racking the slide FAST (recoil speed) letting your hand fly off the end and see if it locks back then.

If you only have ONE magazine, buy at least 2 more factory mags and try them.

The Wiry Irishman
February 26, 2009, 11:24 AM
It's probably locking open with an empty mag because you're pulling the slide back SLOWER than it comes back under recoil. This gives a weaker mag spring and/or dirty slide stop more time to get into the proper position. Try racking the slide FAST (recoil speed) letting your hand fly off the end and see if it locks back then.

I definitely agree with you here, but I can't make the slide move fast enough with my hands to get it to fail to lock back.

I have the two mags it original came with, as well as two brand new factory mags. I'll try disassembling all of them and cleaning them, as well.

dfariswheel
February 26, 2009, 07:47 PM
Possible missing/fouled/or broken slide stop spring.

Part number 31:
http://www.stevespages.com/ipb-walther-pp.html

This fits into a slot on the top of the slide stop.
It's often lost during disassembly for cleaning.

If you enjoyed reading about "PPK failing to lock back on empty mag" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!