Arsenal SLR 106Cr Double feed help!


PDA






Click Click Boom
February 26, 2009, 01:46 AM
I have a Arsenal SLR 106CR That is Double feeding about twice every 30rnd mag. It fires and ejects one round and then double feeds the next 2. What causes this?

Is this a mag issue?

I am using Circle 10 mags and this was the rifles first time to the range. Is this a issue that will "break in"? I was surprised at the rifles acuracy.

If you enjoyed reading about "Arsenal SLR 106Cr Double feed help!" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Kurt_D
February 26, 2009, 02:23 AM
that sounds like a mag issue; how many mags do you have? does it do it every mag? These are the waffle pattern circle 10s not the smooth `74 circle 10s?

Click Click Boom
February 26, 2009, 04:31 AM
Correct, the waffle pattern Circle 10s.

It didnt do it with a 20 round mag but it did with three different waffle circle 10 mags.

Could this "wear in"?

briansmithwins
February 26, 2009, 11:03 AM
Kinda sounds like the receiver may be out of spec and letting the mag ride too high.

I'd probably call Arsenal and get a warranty repair started. The Circle 10 mags should work perfectly with that weapon.

You did get 5.56 mags ans not 5.45, right?

BSW

Click Click Boom
February 26, 2009, 02:44 PM
Yep, they are 5.56 Circle 10 mags

Click Click Boom
February 26, 2009, 05:49 PM
Fed. XM193 is double feeding in multiple Waffle Circle 10 mags.

Rem .223 shoots just fine

The average OAL for 10 rounds of fed XM193 is 2.251. The average OAL for the rem .223 is 2.231. I put 90 rds of each thru three different mags. No problems with the rem.

If you enjoyed reading about "Arsenal SLR 106Cr Double feed help!" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!