Sig P229 problem and range report


PDA






Silvanus
March 7, 2009, 02:12 PM
I took my new Sig P229 (9mm, DA/SA) to the range today. After loading up 2 magazines to full capacity (13 rounds) I started shooting at 15 meters. After about 6 or 7 rounds I checked the target and was happy to see all the shots in a tight group right in the center of the target :) The trigger and accuracy of this pistol are amazing. I've never shot a gun before where the sights were zeroed perfectly right out of the box for me.

I continued shooting when I noticed a too light primer strike. I've shot this ammo in my other pistols (Glock & BHP) and it always worked so far (Magtech, Hirtenberger & Geco). It happened several times with all brands and the rounds all went off on the second strike.

Another problem I noticed was that the slide didn't always lock back after firing the last round. And I know that I didn't put my thumb on the slide lock while firing the pistol. I sometimes did this with my Sig Mosquito, so I know I have to use a different grip than the one I'm used to (and I did).


Now I'm a little disappointed, because I expect a Sig to work flawlessly right out of the box. And apart from the malfunctions I really like this gun a lot.

Do you have any ideas/suggestions, what could be the cause of the problems I'm having with this pistols and how I could fix them? Or should I go back to my dealer and have him send the pistol to Sig Sauer to fix it?

http://i80.servimg.com/u/f80/11/50/35/28/p1010011.jpg (http://www.servimg.com/image_preview.php?i=186&u=11503528)


Here's a photograph of the primer. Is this normal for a Sig? Shouldn't the firing pin hit the center of the primber?

http://i80.servimg.com/u/f80/11/50/35/28/dsc00110.jpg (http://www.servimg.com/image_preview.php?i=187&u=11503528)

If you enjoyed reading about "Sig P229 problem and range report" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
metallic
March 7, 2009, 02:44 PM
Is it failing to lock back on the last round with both magazines? If not, maybe one has a bad follower. It sucks, but it does happen. As for the light strikes, I wouldn't worry until I went back to the range a second time. It might just be that you got a bad lot of ammo.

Runningman
March 7, 2009, 04:12 PM
Here's a photograph of the primer. Is this normal for a Sig? Shouldn't the firing pin hit the center of the primer? Do all the fired cases look like that? My Sig 229 primer strikes do not look like that.

Silvanus
March 7, 2009, 04:17 PM
Is it failing to lock back on the last round with both magazines?

Yes. And both magazines (as well as the gun) are brand new.


It might just be that you got a bad lot of ammo

The different brands are all from the same case (1k rounds) and they worked well in my other pistols.

If you enjoyed reading about "Sig P229 problem and range report" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!