Ruger SR9


PDA






orionengnr
March 14, 2009, 09:13 PM
Took a new shooter to the range Thursday evening. Her hubby had bought her a Ruger SR9, and it was my first chance to see/fire one. She also brought a Ruger MkI (another of his guns) which was so filthy/fouled that the range officer who checked us in recommended that she not use it.

I started her off with my MkIII Hunter, and she did just fine with it. Eventually, she wanted to try the SR9, but wanted me to put a mag through it first. I noted that it looked dry as a bone, but gave it a try. About every other round, it failed to return to battery (by about 1/8") and would not fire. A tap on the back of the slide fixed it for a round or two.

This continued regardless of who shot the pistol.

Additionally, she experienced a number of failures to fully cycle (spent casing was not ejected, apparently short-cycled, no jam, but subsequent trigger pull resulted in a "click" and upon manual cycling, a spent case was ejected).

We only put 30 rounds through it, and there were so many failures each mag that it totally shattered her confidence in "her" pistol (that her hubby had bought for her).

I did a search for SR9 failures, etc, but came up dry (as her SR9). Should I get her to bring it back, lube it up and give it another try? Or is there something I'm overlooking?

FWIW, I've owned and fired 9mms in Ruger, Kahr, Glock, XD, K-T and others.
Ammo was Blazer aluminum case.

If you enjoyed reading about "Ruger SR9" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Bill of Ojai
March 14, 2009, 09:18 PM
Were you using range reloads? I have that problem in some of my guns from lack of adequate case resizing and/ or lack of lubrication.

QuietEarp
March 14, 2009, 09:27 PM
Is this the first time the pistol has been shot?
Was it bought used?
Failures with different magazines or the same one?
I would try the easy fix of lube and inspect the magazines and firearm thoroughly as a start.
At least Ruger is known for it's "warranty."

orionengnr
March 14, 2009, 09:34 PM
As stated in OP, ammo was Blazer aluminum case ammo.
As stated in OP, this was a brand new gun, first time fired.

QuietEarp
March 14, 2009, 10:19 PM
orionengnr, I read the OP and it states that the SR 9 hadn't been fired by either of the shooters and that is was purchased by the husband. It does not state if it was purchased new vs used.

orionengnr
March 15, 2009, 09:54 AM
I am the original poster :)
It was brandy-new and dry as a bone.

shamanjp
March 15, 2009, 10:16 AM
I have an SR9 and it has never done this. I cleaned and lubed it before my first trip to the range and again after each trip. I would give that a try first, and call Ruger if it does not fix the problem. Mine eats blazers just fine.

gidaeon
March 15, 2009, 10:33 AM
Clean. Lube. Bring other additional good brass factory new ammo to try. Fire away. Log all data and\or mishaps. If still bad call Ruger. If good minus Blazer, continue testing\logging Blazer and still call Ruger.

Note: when I lived in IA I loved shopping at Scheels retail chain, NOT because of prices - but because they truly had a no questions asked return policy for several weeks on firearms new or used. If you got a lemon or whatnot you could go in and return or exchange. I actually took advantage when I bought a used pistol and had to exchange for new.

swiftak
March 15, 2009, 12:17 PM
Um, try a little gun oil and some ammo that you know where it came from. My SR9 fires fine with reloads and factory ammo. Usually a new gun has oil on it.

orionengnr
March 15, 2009, 12:26 PM
Please understand that she brought her gun and her ammo. By the time we fired it, options were limited. I had no oil with me (there is now a small bottle in my range bag) and the range had zip, zilch, nada 9mm ammo. I was shooting 45 and 357, so what we had was what she had brought.

Next time I will be more prepared. :)

DMZ
March 15, 2009, 12:47 PM
Should have went out to your car and pulled the autotranny dipstick. Drip a few drops on the slide.

The Lone Haranguer
March 15, 2009, 01:10 PM
Even a Glock cannot function forever devoid of lubrication. :p

orionengnr
March 15, 2009, 05:56 PM
Should have went out to your car and pulled the autotranny dipstick. Drip a few drops on the slide.

My car's a manual tranny...but I guess I could have used the oil dipstick.

By the time she got around to the 9, we were well into our one-hour session. To do the trick, I'd have had to leave the range, get the rangemaster to lock the gun, walk out the front, have the greeter unlock the gun, walk to the car, do the deed, walk back in and have the greeter lock the gun, walk back to the range and have the rangemaster unlock the gun...nah.

As I say, I'll be prepared next time.

trekgod3
March 15, 2009, 06:02 PM
get the rangemaster to lock the gun, walk out the front, have the greeter unlock the gun, walk to the car, do the deed, walk back in and have the greeter lock the gun, walk back to the range and have the rangemaster unlock the gun...nah.

Wow. Where do you live that they lock your gun when you leave the range and go to your car? They physically put a lock on you gun? I've never heard of such a thing. No rangemaster or employee is handling my guns. I hope they take responsibility for any damage caused by employee handling or from the lock.

orionengnr
March 15, 2009, 07:08 PM
Bass Pro, Grapevine, TX.
When you walk in the front door, you hit the greeter's stand. They put trigger locks on each gun, and then you walk through the store and to the range. At that point they unlock your guns, you go shoot. Reverse the process on the way out. When you walk out the front door, the pistols are unlocked.

If you have a CHL (I do) you can retain your cary weapon, loaded and on your person, as long as it remains concealed.

The locks they use are two-piece, with rubber contact surfaces, no problem.

chieftain
March 15, 2009, 07:41 PM
First clean your weapons, particularly brand new ones, when you take it down for inspection, tweaking, cleaning and lubrication.

Second, I have not met a shooter that didn't carry some kind of lube in their bag.

Third, I haven't had a FTF on the SR9 I picked up used about a year ago. I have about 1200 rounds through it. I got it to play with because it was cheap. I like it, but it ain't going to replace my 1911's or HighPower's.

Go figure.

Fred

lanternlad1
March 15, 2009, 08:00 PM
Ammo was Blazer aluminum case.

There is your problem right there. I've had that ammo bind up my CZ P-01 and my Glock 19. It is the crappiest ammo made. Try shooting something with a brass casing through it.

orionengnr
March 15, 2009, 08:17 PM
Thanks for all the replies. The suggestions on lubrication are moot; read the OP and the succeding ones.

The next time she brings it, it will either be lubed or I will add lube; what's done is done.

As far as the Blazer aluminum cased ammo goes, I have limited experience with it, but I find it curious that some are willing to lay all the blame at the feet of the ammo when they obviously sell a good bit of it (just like the steel-cased Wolf).

Not to say that it may not be problematical...one of my (many) revolvers didn't like it either (difficult extraction in a Scandium cylinder).

hometheaterman
March 16, 2009, 01:24 AM
To be honest I've never seen or heard of a SR9 jamming before now. These are known for being very reliable guns from everyone I've talked to that's had one and from every article I've read. I'd have her send it to Ruger. I'm sure they will take care of it.

I would first try some oil on it though. If that doesn't work contact Ruger for sure.

Dookie
March 16, 2009, 06:04 AM
over 2,000 rounds of CCI Blazer in 4 different centerfire pistols, not a single jam. I did have some 27 dollar a box of 20 jam up on me.

It could be the ammo, but as mentioned many times, clean the snot out of it and then lube it. What does the owners manual say?

panther22
March 16, 2009, 09:31 AM
I bought a brand new SR9 last month. Lubed it before going to the range first time, took PMC Bronze ammo with me. It jammed constantly. I thought the gun was broken.
Before sending it back to Ruger, I was encouraged to try Win. White Box ammo. I did, and it was a whole different experience. It worked fine with that ammo.
The SR9 has to be the tightest gun I've ever shot new. I've never had a gun that required so much breaking in to get it to work right. Guys at one of the Ruger forums talk about the gun needing 500 rounds to be really past the break-in period.
You didn't mention the mags. The springs on my mags were so tight that I could only get three rounds in it first time I tried. It took awhile before I could get up to ten rounds in it.
I've still got my SR9, but I don't have the confidence in it I had for the old "P" series Rugers.

chieftain
March 16, 2009, 03:18 PM
I did have issues with the early non-brass Blazer ammo when it first came out. That was before they put the "coating" on it.

Wouldn't run out of my SIG 220's back then. I have stayed away ever since. It may work, I just don't trust it. Those early 220's were pretty reliable guns.

Go figure.

Fred

If you enjoyed reading about "Ruger SR9" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!