Need help with DSA FAL feeding issues


PDA






Savagesweat
June 7, 2009, 07:37 PM
I just received my new STG58 from DSA. I didn't get to shoot it a whole lot last time I went to the range, maybe 40-50 rounds of nice Lithuanian stuff in a couple different mags DSA sold me. I finally thought I got the gas port calibrated properly, but then I had some feeding issues, which I don't think are all related to the gas port. Most frustrating was the two or three occasions where the empty brass would eject correctly, but then as the new round was getting pushed off the top of the mag, it would get stuck halfway, as if the spring was not strong enough to force it into place. What the heck? Is there any reason this should be happening?
The second matter is not as problematic, but still strange, I think. Once I got the gas set right, I let a couple buddies shoot it and it worked fine. Then I let a third guy try it and when he fired it, the brass would not eject nearly as far it did previously. Also, one of the jams occurred with this guy shooting. Could the rifle actually be ejecting differently for different shooters?

If you enjoyed reading about "Need help with DSA FAL feeding issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Bwana John
June 7, 2009, 09:56 PM
A. Friction is not your friend. New park jobs are kinda gritty.
B. FAL's are a little sensitive on how you hold them, some people "weakwrist" em and it affects how well they eject.

Either:
Give it more gas
or
Shoot it 300 rnds or so it will smooth out and feed better
or
Polish the bottom of the receiver feed rails

Hopefully WEG or someone else will post his pics of where to polish.

W.E.G.
June 8, 2009, 12:43 AM
see http://www.falfiles.com/forums/showthread.php?s=&threadid=108077

If you enjoyed reading about "Need help with DSA FAL feeding issues" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!