Help with WASR 2


PDA






chuwee81
July 27, 2009, 02:09 PM
HI there. I took my wasr 2 (5.45) to the range and had an issue. I know, it's a low quality stuff, but i think an AK is an AK and should be able to take a lot of beating.

So i got it a couple of days ago, clean it out, etc. I got 2 mags for it, seems new, ahd numbers 21 and 23 but they're not in a circle, Just numbers.

Now at the range, it would fire 2-3 rounds ok, then there would be a stoppage. Mind you it's not FTF (feed, fire) OR FTE - sort of. WHat happened was the round got pulled/ cleared from the chamber BUT got tossed up inside the dust cover. Somehow the ejector or extractor pulled the shell out but tossed it in different direction. So the bolt carrier was held back by the wandering empty case inside the dust cover. Sometime it's bad enough to lift the dust cover.

Seeing this, i took off the dust cover while shooting and it performed flawlessly. Accuracy is ok, what i expected from an AK, plus it's iron sights and i'm not really good with it yet. Overall I am happy with this thing but i don't want to take the dust cover off just to shoot it.

So any suggestions ?? This is second hand so could not return it to century.

If you enjoyed reading about "Help with WASR 2" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
doc2rn
July 27, 2009, 02:13 PM
Probably an incorrectly cut dust cover, might just need a dremmel tool and a little time.

If you enjoyed reading about "Help with WASR 2" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!