Mossberg 930 SPX problem


PDA






SarcoBlaster
November 14, 2009, 04:01 PM
I was out at the range today and ran into a strange problem with my Mossberg 930 SPX. After loading the magazine tube with 7 shells (2 3/4"), pulled the bolt knob backwards and let it go, but it didn't chamber a round.

After cleaning it at home, I loaded the magazine tube up with 7 rounds again and the same problem popped up. For some reason, the first shell is not being released when I pull the bolt back and release it. However, if I only load 6 in the magazine tube, everything works as it should; pull the bolt handle back, let it go, and it chambers a shell.

Any idea why it doesn't do this with a full magazine tube? If so, what can I do about it because it's driving me nuts.

Any help will be greatly appreciated.

Thanks!

If you enjoyed reading about "Mossberg 930 SPX problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
orphanedcowboy
November 14, 2009, 04:19 PM
Sounds to me as if the mag release has too much pressure on it, and not allowing it to fully release with a full house.

What additions to the gun?

Mag spring factory, factory extension, ect?


How did you get the rounds out of the mag?

SarcoBlaster
November 15, 2009, 01:31 AM
The only additions I have on the gun are a Wilson Combat forward sling mount and a Nordic Components barrel/magazine tube clamp. Factory extension, mag spring, and follower. I removed both the sling mount and clamp, but it did not alleviate the problem.

I used the bolt release button to empty the magazine since it also allows you to unload one round at a time.

Since it releases the shells fine with 6 rounds in the tube, I'll probably just get a Wilson Combat hi-viz follower since it reduces capacity by 1 anyway.

EdLaver
November 15, 2009, 02:42 AM
Directly feed your 1st shell into the chamber with the slide locked back, then hit the release, now load the tube with the remaining 7 (total 8 rounds 7+1) and shoot it then for functionality.

SarcoBlaster
November 15, 2009, 08:46 AM
EdLaver: I was doing what you suggested at the range and it worked fine.

indianahoosiers
November 24, 2009, 11:33 AM
I have the same gun and have been having the same problem since I bought it. EdLaver's suggestion works just fine for going to the range but I use this gun for self defense in my home and as such, I keep the magazine full but do not chamber a round. It worries me that in a time that I may need to use it, I may not be able to get a round in.

Also, I know that the manual says that I should be able to eject one round at a time from the magazine, but when I pull the release, it spits out all the rounds at once. I don't think these problems are connected but I thought I would mention it.

EdLaver
November 24, 2009, 07:53 PM
Contact Mossberg and let them know of the problems you are having. They have great CS. How is the cycling when fired? Any feeding or ejection problems?

It is ok to have a shell chambered and leave it that way, thats what the safety is for. Know your weapon and how it operates, I have had mine for about 4 months and in the initial 25 shots it jammed maybe 4 to 5 times but since then, no problems. I have at least 200 shot fired so far with all types of loads, buckshot, birshot, and slugs. I have used it in tactical shoots and training, just like with all my other shotguns, I shoot 7 shots at a time, then begin feeding the mag tube always leaving the 8th round chambered. If I do happen to shoot the 8th round and the slide locks back, I use the method mentioned before, directly feed a shell into the chamber, release the slide and then begin feeding the tube.

If you enjoyed reading about "Mossberg 930 SPX problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!