Could someone suggest Pmag adjustments?


PDA






Grassman
December 29, 2009, 08:53 PM
I am having a feed problem with some new Pmags through my Bushmaster. Are there any adjustments that need to be done? Rough edges or spring adjustments? Any web links would be helpful too. Thanks.

If you enjoyed reading about "Could someone suggest Pmag adjustments?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
taliv
December 29, 2009, 08:54 PM
nope. nothing to adjust.

do other mags work in the bushamster? do the pmags work in other guns?

Shadow Man
December 29, 2009, 08:57 PM
There's not really much you can do to a PMAG...in fact, this is the first I've ever heard of an un-damaged one not running flawlessly...

Grassman
December 29, 2009, 09:03 PM
A brand new Bushie and two brand new Pmags, almost positive it's the mags. Could it be the ammo? Remington UMC and Hornady ammo.

NetJunkie
December 29, 2009, 09:04 PM
Two PMags? Yeah..adjust the gun. Not the mag. Do you have any GI mags and do they work?

wally
December 29, 2009, 09:06 PM
If a different brand of mag don't work contact Bushmaster. There was another thread somewhere about a new Bushmaster not feeding from new C-Products mags. Bushmaster had them return the gun and the mags and they fixed the issue.

--wally.

Al Thompson
December 29, 2009, 09:06 PM
almost positive it's the mags

Hate to say it, but I don't think it's the mags. :( I've run PMAGS in M4s, Stag, S&W, Colt....

Try different (metal) magazines. :uhoh:

Z-Michigan
December 29, 2009, 09:32 PM
Could it be the ammo? Remington UMC and Hornady ammo.

What is the exact ammo - bullet weight, type and nose shape?

What are your exact feeding problems?

W.E.G.
December 29, 2009, 09:39 PM
Describe the exact nature of the "feed problem."

Is this a factory-built Bushmaster?
Describe the configuration of the rifle.

How many rounds have you had through it?

What sort of lubricant are you using?

Mags
December 29, 2009, 09:42 PM
Do you have real M4 feed lips in your rifle?

taliv
December 29, 2009, 09:58 PM
ever spent the night in a Turkish prison?

Grassman
December 29, 2009, 10:02 PM
The ammo was Hornady FMJ/BT 55grain and Remington UMC 55 grain. Factory Bushmaster predator 20" 1:8 twist. Just after every shot had to pull the bolt back to chamber each round, it just wasn't feeding from the mag right(or so I thought). Brand new Bushie, I did not lube before first shooting, should I have?

Grassman
December 29, 2009, 10:04 PM
How do i determine if I have M4 feed lips? Pretty new to AR's so still learning here.

BurningSaviour
December 29, 2009, 10:06 PM
M4 feed ramps aren't going to make a difference. I only have one Pmag and haven't fired it yet (I'm a bit skeptical of non-metal AR mags after bad experiences with Tapco and Meg-Car mags), but I've yet to see any report of problems with them. I've gotten enough feedback from people who've bought them from me before deploying to Afghanistan or Iraq, and it was all positive.
I've known a couple instances of Bushmasters being a bit fickle about which magazines they'll accept. I remember something about them not accepting Orlite magazines some time ago. But if there was a problem with Bushmasters and Pmags, the word would've been out by now.
I've just noticed that you said you were shooting Remington UMC ammo, and that might be the problem, or part of it, there. While some AR owners sing its praises, there've been a lot who've had serious issues with it. Olympic and Adcom ammo gets a lot of the same negative feedback.

And yes, you should lube the rifle. And I've yet to see a Bushmaster rifle which is M4 cut with the feed ramps. It's not going to make any difference, anyhow.

http://www.ar15barrels.com/tech/feedramps2.jpg

Grassman
December 29, 2009, 10:12 PM
I gonna take the factory 5 shot steel mag out and try it, see if there is any improvement.

Z-Michigan
December 29, 2009, 10:27 PM
Just after every shot had to pull the bolt back to chamber each round, it just wasn't feeding from the mag right(or so I thought). Brand new Bushie, I did not lube before first shooting, should I have?

I suspect your problem is one or both of:
1) Rifle dry - AR15s must be run wet (well lubed) and especially so when brand new.
2) It could also be that the magazine wasn't inserted fully. On most ARs, especially with a larger mag like a Pmag, it is possible to have the mag in almost far enough - far enough that it looks right and won't fall out - but in fact it is about 0.1" away from being latched and as a result just low enough that rounds won't feed reliably (if at all) from the magazine.

And taliv, no, but I do like movies about gladiators.

Clean and lube the rifle thoroughly, including the bolt to carrier fit and the carrier bottom rails. Try shooting again, being 100% certain that the magazine is fully inserted and latched, and try the OEM 5-round mag for comparison.

Grassman
December 29, 2009, 10:36 PM
I plan on it. Thanks.:D

Z-Michigan
December 29, 2009, 11:10 PM
The ammo was Hornady FMJ/BT 55grain and Remington UMC 55 grain. Factory Bushmaster predator 20" 1:8 twist.

Just to add two things:

A) Your ammo should be fine, especially the Hornady which is fairly consistent high quality ammo. UMC has looser quality control, but I personally have never had an ammo problem with UMC .223 (55gr FMJ) and I've shot 1000's of rounds of it, mostly in AR-15s.

B) Your rifle, with 20" barrel and rifle gas system, doesn't need M4 feedramps and likely would not benefit from them. M4 feedramps are a benefit with 16" and shorter barrels with carbine length gas systems. Since yours is the design originally intended, it doesn't need the help for reliable feeding.

W.E.G.
December 29, 2009, 11:14 PM
Yes, the rifle must be lubricated.

Your description indicates that the rifle was "short-stroking."
That this occurred with a brand new AR-type rifle with no lubrication, does not surprise me in the slightest.

Get some Break Free CLP and spray it on the bolt, the bolt carrier, and the recoil spring assembly.

DO NOT use grease as a substitute for CLP.

Tim the student
December 30, 2009, 02:06 AM
ever spent the night in a Turkish prison?

Too funny.

Avenger29
December 30, 2009, 02:30 AM
Try lubing, and if that fails, call both Bushmaster and Magpul for help.

If you enjoyed reading about "Could someone suggest Pmag adjustments?" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!