Help- CZ 75B Omega hammer does not retract enough / gun will not fire


PDA






Niel4
February 6, 2010, 07:31 PM
hope I can explain this ......my 6 month gun was working perfectly (!) and is the most accurate gun I have out of 7 auto's.

It is about 6 months old and has ~300 rounds through it. I took it to the range and after the first 3 shots fired I went to pull the trigger and nothing.... it would not move. The prior round ejected fine, the slide racked ok and the next round chambered ok. I racked the slide again ejecting the round and it fired normaly when i pulled the trigger,,,,then it happened again.

What I have been able to figure out is the hammerr goes about 95% "back" when the slide racks.....if i manualy move the hammer the last 5% it fires fine. The next round may or may not fire normaly. If I pull the hammer back again that last 5% it works fine. I will get 5-8 of these out of a mag. Its not the mag as I have 2.

Up unitlll this last range trip it was Perfect....any ideas why the hammer does not seat properly and what I could do about it short of sending it back to CZ?

If you enjoyed reading about "Help- CZ 75B Omega hammer does not retract enough / gun will not fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Runningman
February 6, 2010, 07:49 PM
You may want to look at the trigger return spring see if it is broken.

If you enjoyed reading about "Help- CZ 75B Omega hammer does not retract enough / gun will not fire" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!