Walther PP 32 acp problem


PDA






Byron
March 9, 2010, 05:54 PM
I have an older Walther 32 ACP I recently traded on. New magazines from Walther(S&W) were purchased.Ammo is FMJ: Winchester.Aquila,Prive Partisn, and Fiochi. I have researched rimlock and do not think this is the problem. While firing,it appears the ejected case does not eject full sitting on top the next round.It is not a stovepipe nor is the next round trying to be chambered.This occurs at random. The pistol is well cleaned.Could the extractor be the cause? I am open to suggestions. Thanks, Byron

If you enjoyed reading about "Walther PP 32 acp problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Babbalanja
March 9, 2010, 08:59 PM
I've found that older PPs recoil springs are often weakened and replacing them with new springs usually resolve the problem. I think Wolff makes them or Numrich. Good luck.

BADSBSNF81
March 9, 2010, 09:00 PM
Aside from changing the recoil springs, try some different magazines and different ammunition.

lechiffre
March 10, 2010, 08:10 AM
i would check:
1. different ammo (check)
2. different magazine (how about the old one?)
3. extractor spring
4. extractor
5. recoil spring

Byron
March 10, 2010, 11:13 AM
First, let me thank y'all for the responses. The old magazine did the same. I'll try all suggestions and once done,reply back. Byron

Byron
March 20, 2010, 02:41 PM
I received a new recoil spring from Wollf yesterday. I noted the spring was slightly longer.I went to the range this am.I fired 1 magazine of Aquila, 4 magazines of Fiochi and one stove pipe around the 11th round. I fired on rapid fire and no problems. I do appreciate the help y'all gave.

If you enjoyed reading about "Walther PP 32 acp problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!