Ruger P95 Slide Problem


PDA






BLP1981
May 31, 2010, 07:59 AM
Hi Everyone,

I'm new to the forum and need some help with a Ruger P95 I recently purchased. I've had the gun for about 2 months or so and have put a few hundred rounds through it at the firing range. A few weeks ago the slide would not stay open on the last shot with either magazine. I first took it back to the store I bought it from and they took the mags apart and oiled them. This didn't help so I called Ruger and they told me to try a different brand ammo. I tried this and also bought a new mag, neither helped. I called Ruger back and they sent me a new slide stop assembly and it's not any better.

Does anyone have any suggestions on what's causing this or how to fix it?


Brett

If you enjoyed reading about "Ruger P95 Slide Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
railroader
May 31, 2010, 11:04 AM
Are you using factory ammo or reloads? If you are using reloads they might be loaded too weak which might be your problem. If you shoot thumbs forward make sure your thumb doesn't rest on the slide stop or it won't come up and lock the slide after the last round. Also don't oil the inside of your mags. All that does collects dirt and gums up your mags. Welcome to the forum by the way. Mark

LaserSpot
May 31, 2010, 11:46 AM
Does the slide always lock when you pull it back by hand?

It could be a limp-wristing type failure; try stronger (+p) ammo or a tighter grip.

easyg
May 31, 2010, 12:43 PM
Does anyone have any suggestions on what's causing this or how to fix it?
Send it back to Ruger and let them fix it.

My P95 had some initial problems where it would fail to feed and sometimes fail to extract.
I sent it back to Ruger and they fixed the problems (replaced the ejector and repaired the extractor).
It now works 100%.
It did take about 5 weeks to get it back.

Good luck,
Easy

BLP1981
May 31, 2010, 12:50 PM
Thanks for the replies!

I've tried Remington ammo, Winchester target ammo, and a few others. Yes the slide does lock when it's pulled back by hand with an empty mag.

I checked my grip and my thumb does rest near the slide stop. I'll try a different grip next time I go shooting. I am a beginning shooter by the way. Other than this I've had no other problems with the gun. Not one FTF or FTE.

railroader
May 31, 2010, 02:00 PM
That ammo should work fine. If it isn't your grip send it back to ruger and let them figure it out. Mark

BLP1981
June 6, 2010, 11:13 AM
I went to the range this morning and changed my grip and had no problems with the gun. Thanks for the help guys.

biggoofy
June 6, 2010, 12:12 PM
Have had the pistol about 5 months and have about 800 rounds through it. After about 200 rounds it starts jamming - misfeed, stovepipe, and empty shell casings sticking in the chamber - mostly using Federal 115 gr target ammo. Sometimes the slide does not stay open after the last round is ejected. The slide at this point is too hot to hold on to, which may be normal. Slide sometimes does not stay open after last round ejected. May try lubing the mags - is it better to use oil or graphite?

JDGray
June 6, 2010, 01:17 PM
I wouldn't oil the mags, they run dry, so dirt and stuff wont stick inside. OP found his problem by changing his grip. I had the same problem, but with a Sig 239, bad place for the stop(or for my thumb:D)

Welcome to both of you newbies!

Caliper_RWVA
June 6, 2010, 01:20 PM
These problems sound like the gun is short cycling. Could be limp wristing, but more likely related to slide lube. My P95 has done this on two separate range trips.

First time was the first trip to the range. Didn't know any better yet, hadn't cleaned the gun (bought new) and the slide had a thick grease on it. Add cold weather and it was short cycling all over the place. Spent cartridges not fully ejected and the slide stop not engaging.

Second time was another cold weather trip. After 200 or so round in 20F weather and the same thing was happening again. The rangemaster had some light spray lube that cleared it up.

Seems that the slide has to get all the way back to let the hold open engage, but the hammer and trigger will reset much earlier. If everything works when cycling the gun manually, I would lean towards it being a lube related issue or maybe fouling?

If you enjoyed reading about "Ruger P95 Slide Problem" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!