problem with Gun Vault


PDA






SSN Vet
July 27, 2010, 02:01 PM
I've had the multi model gun vault anchored under my night stand for years and absolutely love it.

I've wanted to put one on the ground floor for some time, so when Midway had the single model on sale for $80, I snarfed one up.

Took me a while to figure out where I wanted it and to get it installed.

Now I'm having a problem with it, as the catch seems to be binding, so that it fails to open with the key pad about 50% of the time.

It opens right up with the key, which seems to release the catch with more positive action.

Tried a squirt of WD40, but still not functioning reliabley.

Any one else out there dealt wth this problem?

I'm not so crazy about the new grey finger buttons. I liked the older style better. But that shouldn't have anything to do with the catch hanging up.

If you enjoyed reading about "problem with Gun Vault" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!
Fumbler
July 27, 2010, 02:42 PM
Check the basics first...are the batteries good?
I know with mine if the batteries start to lose juice then they won't have enough power to open the latch.

rbernie
July 27, 2010, 03:10 PM
I know with mine if the batteries start to lose juice then they won't have enough power to open the latch. This.

SSN Vet
July 27, 2010, 05:14 PM
brand new batteries...

I suppose I could change them out...

when I reach my finger in and manually toggle the catch, it feels tight and rough.

swinokur
July 28, 2010, 11:30 AM
Call Gunvault. Their CS is excellent. I had lock problems with 2 of their products, one out of warranty. Both times. s soon as I called, they cheerfully sent replacements with a prepaid UPS label for return shipment.

Both replacements have worked without a hitch since then. One was a mini vault for my car and the other was a Multivault deluxe.

I am satisfied with the product because Gunvault stands behind the product's warranty (even if more than a year old)

SSN Vet
July 30, 2010, 05:16 PM
mystery solved....

bad batteries...

They were name brand (Panosonic) and in unopened packaging, just recently purchased from the store.

But.... my wife got them on sale at the Christmas Tree Store :barf:

I didn't check the date, but I'll wager they were old.

Replaced them with new Alkalines and the problem is solved.

I can hear the difference wrt. how much "authority" there is in tripping the catch release.

I'll have to save these batteries for one of the kids talking toys now :)

If you enjoyed reading about "problem with Gun Vault" here in TheHighRoad.org archive, you'll LOVE our community. Come join TheHighRoad.org today for the full version!